Jump to content
Sign in to follow this  
Guest house

Asuswrt-Merlin nie działa FTP

Rate this topic

Recommended Posts

Guest no4fly1

Witam

po zmianie firmowego oprogramowania na Merlina nie działa mi FTP.

W czym może być problem?

Podpięty pod USB dysk jest widoczny w sieci lokalnej, ale nie ma do niego dostępu z sieci zewnętrznej.

Przed zmianą firmware wszystko działało.

Wszystkie ustawienia mam bez zmian.

Share this post


Link to post
Share on other sites
house

po zmianie firmowego oprogramowania na Merlina nie działa mi FTP. W czym może być problem?

przekierowanie portu ? sprawdzasz łącząc się ze swojego LAN'u poprzez publiczny adres, czy z zupełnie innej sieci ?

FTP jest włączone? dysk USB widać w lan po smb czy właśnie ftp ?


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest no4fly1

dziękuję za wyodrębnienie wątku oraz za odpowiedź

 

Przekierowanie nic nie daje zresztą na OFW działało przekierowanie automatycznie.

Włączone Aidisk.

DDNS zarejestrowane i nie pokazuje błędu.

 

Przy takich ustawieniach i z tym samym dyskiem działało na RT-N66U oraz po zmianie na RT-AC68U (na OFW)

a po wgraniu Merlina przestało.

 

Sprawdzam poprzez publiczny adres (przez sieć komórkową tak dotychczas działało)

W lokalnej sieci dysk widać zarówno po smb jaki ftp.

Edited by no4fly1

Share this post


Link to post
Share on other sites
house

używasz host.asuscomm.com ? pokaż jakiś kawałek logu z routera i klienta ftp, problem może dotyczyć listowania katalogów lub trybu passive. rzeczywiście router sam dodaje reguły nat do usług ftp, spróbowałbym przekierować jakiś inny port np 8080 do 21 z ip routera i sprawdził. za mało danych, poza tym, że nie działa.


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
house

z którego wynika tylko tyle, że serwer działa a nie odpowiada na WAN. Przekieruj ręcznie port 8080 do 21 i sprawdź.


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest no4fly1

niestety ustawienie przekierowania nic nie dało

 

 


natomiast przy takim ustawieniu klient ftp daje z sieci zewnętrznej komunikat że nie można znaleźć serwera,

a łącząc się po sieci wewnętrznej - wywołaniu host.asuscomm.com łączy się, no ale nie o to przecież chodzi. 

post-517-0-52945500-1441549989_thumb.gif

Edited by no4fly1

Share this post


Link to post
Share on other sites
house

a powrót do OFW przy takich samych ustawieniach coś poprawia ? zainstaluj FileZilla server, wystaw na WAN i spróbuj się połączyć. Reset ustawień i ustawienie od nowa wykonałbym jako ostateczność.


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest no4fly1

po przywróceniu OFW

 

ftp działa,

 

nie widać katalogów, bo Merlin pozmieniał nazwy, ale to pewnie kwestia ponownego uruchomienia AidDisk,

ale na dysk można się dostać.

 

 

edit 1:

katalogi już się same pojawiły

 

na OFW usunąłem przekierowanie 8080 na 21 i ftp dalej działa z sieci zewnętrznej

 

 

edit 2:

po ponownym wgraniu Merlina klient ftp z zewnątrz przestał się łączyć.

żadnych zmian w ustawieniach nie wprowadzałem

 

 

 

Macie może jeszcze jakieś pomysły czy lepiej wrócić do OFW?

Edited by no4fly1

Share this post


Link to post
Share on other sites
house

zapisz ustawienia do pliku w OFW, wgraj merlina i zresetuj do ustawień fabrycznych. Ustaw od nowa, jak nie pomoże - wgraj OFW i przywróć ustawienia z pliku.


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest no4fly1

na wgranym Merlinie, reset do fabrycznych

zmieniłem login i hasło 

uruchomiłem od nowa ddns 

 

nie działa

 

trudno, wracam do OFW

szkoda

 

 

dzięki za dobre chęci i poświęcony czas

Edited by no4fly1

Share this post


Link to post
Share on other sites
Guest muzykcb

A w ustawieniach:  Udostępnianie FTP włączyłeś:

 

1) Włącz FTP

2) Enable WAN access

 

w OFW nie ma takiej potrzeby merlin wymaga włączenia.

post-136-0-97317500-1441743060_thumb.jpg

 

Share this post


Link to post
Share on other sites
Guest no4fly1

 

 

Wszystkie ustawienia mam bez zmian.

 

Na pewno nie włączałem dostępu WAN.

Po powrocie do OFW ftp działa.

 

Dzięki za podpowiedź.

Zobaczymy czy to było to.

 

Przy okazji po co w Merlinie ta opcja wyłączania WAN access?

Jakie są tego plusy i minusy?

Share this post


Link to post
Share on other sites
house
Przy okazji po co w Merlinie ta opcja wyłączania WAN access? Jakie są tego plusy i minusy?

@muzykcb pyta czy włączyłeś dostęp zewnętrzny, jeśli nie to masz przyczynę. Ja błędnie założyłem, że oczywiście go włączyłeś i dopiero po tym sprawdzasz z WAN'u dostęp :) Plusem jest to, że możesz zdecydować czy serwer ma działać jedynie w sieci lokalnej czy ma być dostępny z zewnątrz. 


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest no4fly1

Potwierdzam - po włączeniu WAN Access dostęp przez ftp z sieci zewnętrznej działa.

Czyli to było to, dzięki muzykcb.

Share this post


Link to post
Share on other sites
house

Temat zamykam jako rozwiązany.


Pozdrawiam

[email protected]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, please see ours Guidelines and Privacy Policy.