Skocz do zawartości
pociej

ASUS RT-AC68U - dostęp do udostępnionych udziałów na PC z zewnątrz.

Oceń temat:

Rekomendowane odpowiedzi

pociej

Hej

 

Mam na PC podłączonym do routera ASUS RT-AC68U udostępnione parę folderów do których chciałbym mieć dostęp z zewnątrz sieci domowej.

 

Z dostępem do plików z urządzeń w sieci LAN poprzez sambę nie mam problemu, jednak gdy chcę skorzystać z nich z innego urządzenia poprzez sieć WAN już nie mogę się połączyć.

 

Próbowałem przekierowywać porty 137, 138 ,139, 445 z zewnątrz na lokalny IP komputera jednak to nie przyniosło skutku.

Nadmienię że udaję mi się połączyć z zewnątrz poprzez ftp z obecnym w sieci NASem dzięki przekierowaniu portów na niego.

 

Proszę o pomoc jak skonfigurować router aby móc skorzystać z plików udostępnionych na komputerze poprzez sambę z sieci WAN.

Jakie porty muszą być przekierowane oraz czy może potrzebuję coś dodatkowo zmienić w systemie (Windows 7).

 

Dzięki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

nie wiem czy to zadziała, gdyż smb wbudowane w asuswrt ma zapewne wyłączony interfejs wan. oczywiście nie możesz tego zmienić (smb.conf tylko do odczytu). rozwiązania są trzy - instalacja samby z entware, moim zdaniem najlepsze - włącz OpenVPN na routerze i loguj się do całej sieci LAN z zewnątrz lub AiCloud 2.0

 

Samba przez WAN to nie najlepszy pomysł, gdyż cała komunikacja leci niezabezpieczonym kanałem który łatwo można podglądać :/

 

Próbowałem przekierowywać porty 137, 138 ,139, 445

137/UDP, 138/UDP, 139/TCP, 445/TCP 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
pociej

Dziękuję za odpowiedź.

Porty przekierowywałem dla obu protokołów także nie tutaj leży problem.

AiCloud z tego co widzę to tylko na smartfon/tablet także odpada.

Brak bezpieczeństwa w Sambie mi nie przeszkadza, szkoda że nie da się z niego korzystać z WAN, w domu się sprawdziło  to i poza nim chętnie bym używał.

Pozostaje VPN, przyjrzę się jutro temu rozwiązaniu.

Niestety napotkałem nowy problem...

Na NASie w sieci lokalnej stworzyłem nowy folder z dostępem dla wybranego użytkownika z hasłem (jak dotąd wszystkie foldery były widoczne dla każdego w sieci).

Okazało się że jest problem przy logowaniu z Windows 7, pojawia się taki błąd:

Z Macbooka, system OS X, czy teleonu z odpowiednią aplikacją korzystająca z Samby mogę do niego uzyskać dostęp bez problemu.

Mogę również się do niego dostać z poziomu Windows XP na wirtualnej maszynie na PC z Windows 7 z poziomu którego nie mogę.

Sprawdziłem również czy mogę się zalogować do innego udziału, tym razie na laptopie, który również wymaga logowania i skończyło się na tym samym.

Od paru godzin siedzę i przeczesuję google (okazuje się że to popularna bolączka Windows 7) jednak żadna z powtarzających się rad nie przynosi skutku.

Co najlepsze jestem prawie pewien że w zeszłym roku przed reinstalacją Windowsa, która została przeprowadzona na początku stycznia, takiego problemu nie było

Może tutaj dostanę jakąś skuteczną pomoc, wszystkie znalezione w google zawiodły.

Dzięki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

nie masz zapamiętanych poświadczeń do jakiegoś udziału w samym windows ? Udziały są publiczne na serwerze ? Konto gościa włączone ?

czy polecenie 

net use * /DELETE /Y

coś pomaga ?

 

czy możesz tak się dostać ?

net use Z: \\adres.serwera.NAS\ZASÓB /user:hasło

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
pociej

Polecenie

net use * /DELETE /Y

rozwiązało cały problem.

Usunęło mi pozostałe zmapowane udziały ale za to teraz wszystkie są dostępne, czy to publiczne, czy zabezpieczone!

 

Serdecznie dziękuje!  :)

 

Oraz też znalazłem że Smart Access w AiCloud działa także przez przeglądarkę (a nie tylko mobilną aplikację) czego chyba nie było w czasie jak kupowałem router...

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Temat zamykam jako rozwiązany.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • GrzegorzZ
      Przez GrzegorzZ
      Witam
       
      Mam wielką prośbę. Na wstępie wyjaśnię krótki opis jak obecnie wygląda moja sieć. 
      Więc mam internet z Orange. Sygnał odbieram Routerem  Huawei 8525s, którego mam kablem podłączonego do Asusa 4G-AC68U (troche chore, ale spowodowane jest to dziwnym zjawiskiem. Jak mam kartę włączoną do Asusa to mam bezpośredni transfer na kompie mierzeny na speedtest 2-5MB/s, jak mam kartę do Huaweia to mam ok 7MB/s ,a jak mam Huaweia podłączonego do Asusa, mam 20-30MB/s, ot, zjawisko dla mnie nie do wyjaśnienia).Kontynuując, od Asusa mam połączony kablem Switch TP-Link  TL SF1008D,od którego mam odprowadzone kable do 4 dekoderów (tak aby były w jednej sieci). Tak więc Asus jak dobrze rozumiem ustala sieć na mój dom wysyłając sygnał przez kabel i jednocześnie Wi-Fi (które również jest rozprowadzone przez Routery "gniazdkowe" jako wzmacniacze). Do sieci WI-Fi jest podłączona drukarka.
      Co ja bym chciał??? Mianowicie, marzy mi się ,aby zrezygnować z "gniazdkowych" i tak zrobić sieć ,aby w pomieszczeniach, których mam rozprowadzone kable podłączyć bezpośrednio pod nie Router, który by wysyłał sygnał Wi-Fi oraz podłączyć do niego dekoder. I co kluczowe. To musi być jedna sieć (przynajmniej dla dekoderów oraz dla sieci Wi-Fi). Na razie podłączyłem Tp-Linka WR743 ale nie mogę tego ustawić. Jak już udało mi się ,aby dekodery się widziały to znów sieć Wi-Fi jest inna i drukarki nie widzę. 
      Pytanie czy jestem w stanie to zrobić (pewnie wszystko się da) na tym co mam ? czy muszę coś do kupić ? 
       
       
    • Konradi95
      Przez Konradi95
      Witam
      Co mogą państwo poradzić w takiej sytuacji?
       
      Od razu dopowiem,
      Router nie ma wystawionego GUI do WAN, tak samo telnet i ssh.
      hasła dosyć mocne(reguła silnego hasła)
       
      fw najnowsze z sierpnia
       
      Pozdrawiam

    • cross099
      Przez cross099
      Cześć
       
      Z racji że w domu wymieniłem sprzęt sieciowy i wszystko zaczęło działać tak jak sobie to wymyśliłem ( w końcu po Wi-Fi transfery są rządu 220Mb/s+) chciałbym aby laptop który nabędę też dawał radę. Kwestia karty wifi i informacji o niej jest traktowana trochę po macoszenu. Nigdzie nie mogę znaleźć informacji jaką karta jest wsadzona do tego Asusa, a nawet czy jest szansa na wymianę w razie klapy.. 
       
      Wiem że Intel 9260 czy Killer 1550 to nie będzie ale czy w razie czego możnaby było na taką kartę wymienić to co siedzi w środku ? Słyszałem dość ciepłych słów o tych kartach...
       
      U mnie w domu na AP robią UAP UniFi AC LR.  Każde napędza jedno piętro. Ok 60 m^2.
       
      Dzięki za pomoc i wskazówki.

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Wszystkie wymagane w tej kwestii informacje zawierają: Polityka prywatności, Regulamin oraz Warunki użytkowania.