Skocz do zawartości
pociej

ASUS RT-AC68U - dostęp do udostępnionych udziałów na PC z zewnątrz.

Oceń temat:

Rekomendowane odpowiedzi

pociej

Hej

 

Mam na PC podłączonym do routera ASUS RT-AC68U udostępnione parę folderów do których chciałbym mieć dostęp z zewnątrz sieci domowej.

 

Z dostępem do plików z urządzeń w sieci LAN poprzez sambę nie mam problemu, jednak gdy chcę skorzystać z nich z innego urządzenia poprzez sieć WAN już nie mogę się połączyć.

 

Próbowałem przekierowywać porty 137, 138 ,139, 445 z zewnątrz na lokalny IP komputera jednak to nie przyniosło skutku.

Nadmienię że udaję mi się połączyć z zewnątrz poprzez ftp z obecnym w sieci NASem dzięki przekierowaniu portów na niego.

 

Proszę o pomoc jak skonfigurować router aby móc skorzystać z plików udostępnionych na komputerze poprzez sambę z sieci WAN.

Jakie porty muszą być przekierowane oraz czy może potrzebuję coś dodatkowo zmienić w systemie (Windows 7).

 

Dzięki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

nie wiem czy to zadziała, gdyż smb wbudowane w asuswrt ma zapewne wyłączony interfejs wan. oczywiście nie możesz tego zmienić (smb.conf tylko do odczytu). rozwiązania są trzy - instalacja samby z entware, moim zdaniem najlepsze - włącz OpenVPN na routerze i loguj się do całej sieci LAN z zewnątrz lub AiCloud 2.0

 

Samba przez WAN to nie najlepszy pomysł, gdyż cała komunikacja leci niezabezpieczonym kanałem który łatwo można podglądać :/

 

Próbowałem przekierowywać porty 137, 138 ,139, 445

137/UDP, 138/UDP, 139/TCP, 445/TCP 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
pociej

Dziękuję za odpowiedź.

Porty przekierowywałem dla obu protokołów także nie tutaj leży problem.

AiCloud z tego co widzę to tylko na smartfon/tablet także odpada.

Brak bezpieczeństwa w Sambie mi nie przeszkadza, szkoda że nie da się z niego korzystać z WAN, w domu się sprawdziło  to i poza nim chętnie bym używał.

Pozostaje VPN, przyjrzę się jutro temu rozwiązaniu.

Niestety napotkałem nowy problem...

Na NASie w sieci lokalnej stworzyłem nowy folder z dostępem dla wybranego użytkownika z hasłem (jak dotąd wszystkie foldery były widoczne dla każdego w sieci).

Okazało się że jest problem przy logowaniu z Windows 7, pojawia się taki błąd:

Z Macbooka, system OS X, czy teleonu z odpowiednią aplikacją korzystająca z Samby mogę do niego uzyskać dostęp bez problemu.

Mogę również się do niego dostać z poziomu Windows XP na wirtualnej maszynie na PC z Windows 7 z poziomu którego nie mogę.

Sprawdziłem również czy mogę się zalogować do innego udziału, tym razie na laptopie, który również wymaga logowania i skończyło się na tym samym.

Od paru godzin siedzę i przeczesuję google (okazuje się że to popularna bolączka Windows 7) jednak żadna z powtarzających się rad nie przynosi skutku.

Co najlepsze jestem prawie pewien że w zeszłym roku przed reinstalacją Windowsa, która została przeprowadzona na początku stycznia, takiego problemu nie było

Może tutaj dostanę jakąś skuteczną pomoc, wszystkie znalezione w google zawiodły.

Dzięki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

nie masz zapamiętanych poświadczeń do jakiegoś udziału w samym windows ? Udziały są publiczne na serwerze ? Konto gościa włączone ?

czy polecenie 

net use * /DELETE /Y

coś pomaga ?

 

czy możesz tak się dostać ?

net use Z: \\adres.serwera.NAS\ZASÓB /user:hasło

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
pociej

Polecenie

net use * /DELETE /Y

rozwiązało cały problem.

Usunęło mi pozostałe zmapowane udziały ale za to teraz wszystkie są dostępne, czy to publiczne, czy zabezpieczone!

 

Serdecznie dziękuje!  :)

 

Oraz też znalazłem że Smart Access w AiCloud działa także przez przeglądarkę (a nie tylko mobilną aplikację) czego chyba nie było w czasie jak kupowałem router...

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Temat zamykam jako rozwiązany.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Wlodek_242
      Przez Wlodek_242
      Hejka. Znów potrzebuję pomocy. Jak pisałem mój router stoi na poddaszu i chciałem połączyć go z routerem na dole kablem ethernet. Mam kable porozciągane ale niezarobione. Wziąłem się za to. Zarobiłem końcówki na górze w standardzie B I na dole do gniazd to samo. Pokazuje mi jednak jakby szukał ale finalnie nie łączy. Generalnie jak na krótkim kablu łącze bezpośrednio do routera to śmiga. Z tego co wiem to długość takiego kabla może być dość dluga. I już nie wiem... Może ktoś jakiś pomysł? Może być, że router "nie ma siły"?
    • muzykcb
      Przez muzykcb
      Cześć.
      Dajcie znać czy tylko u mnie od dobrego tygodnia zarówno na najnowszym sofcie Merlina jak i najnowszym od ASUS-a nie działa narzędzie Download Master
      posiadam: RT-AC68U ale sądzę że w innych może być podobnie.
       
       
    • kaczan81
      Przez kaczan81
      Witam
      W związku z przesiadką z VDSL na FTTH zmeiniłem router z DSL AC68U na RT AC88U. Mam problem z uruchomieniem IPTV od Orange (na DSL AC68U działało) ponieważ nie jestem w stanie przypisać 2 VLAN do jednego portu (w DSL AC68U) byla taka nożliwość. 
      Czy wie ktoś jak to zrobić?

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Używamy plików cookie do celów związanych z reklamami, mediami społecznościowymi i statystykami. Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Wszystkie wymagane w tej kwestii informacje zawierają: Polityka prywatności, Regulamin oraz Warunki użytkowania.