Skocz do zawartości
davero

Zapis dysku z serwera nas pod linuxem

Oceń temat:

Rekomendowane odpowiedzi

davero

Witam mam maly problem :) przegrałem sobie wszystkie dane  pod linuxem z partycji ntfs na partycje serwera nas ext4. (usunałem katalog public :) chyba to był zły pomysł) Po wgraniu danych i podpięciu dysku do nasa ftp widział wszystkie katalogi, ale cześć z nich nie dała się odtworzyć, to samo all share nie widziało tych katalogów. Po przez menadzera w qnapie one działaly (pobieranie kopiowanie) Czy ja usuwając katalog public mogłem tak popsuć cały system (później wgrywałem od nowa wszystko juz na ext3) czy linux mógł wywinąc taki numer ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

Musisz zalogować się przez konsole i zmienić uprawnienia plików. W konsoli musisz zrobić chown i nazwa usera:grupa usera -R a następnie chmod 777 -R. Lub poprzez managera - właściwości folderu i tam je ustawić. To mi wygląda na problem właśnie z uprawnieniami.

Wysyłane z mojego GT-I9300 za pomocą Tapatalk 2

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

Musisz zalogować się przez konsole i zmienić uprawnienia plików. W konsoli musisz zrobić chown i nazwa usera:grupa usera -R a następnie chmod 777 -R. Lub poprzez managera - właściwości folderu i tam je ustawić. To mi wygląda na problem właśnie z uprawnieniami.

Wysyłane z mojego GT-I9300 za pomocą Tapatalk 2

Czyli nie usuwać nic :) nie da się dać swoich katalogów ? Zostawić co zainstalował serwer ? i np wpakowac wszystkie filmy muzę itd. do multimedia ? Chyba będę raz jeszcze musiał pojechać przez linuxa. Zobacze jeszcze po kablu, a jak mam podpiac do kompa nas bezpośrednio jak to się ustawia ? (nie robiłem nigdy czegoś takiego tzn łączyłem kompy dwa ale to w tamtym wieku, więć nie pamiętam)

aha i co ciekawego zauwazyłem zużycie prądu qnap 212 plus toshiba 3tb 12.3w. Ustawiałem aby dysk się wyłączał po 30m później po 5m i nic dysk śmiga cały czas diody się świecą. Pobór 12.3, ftp otwiera sie normalnie dysk się nie budzi. W czym tkwi problem ? Jak to ustawić poprawnie, aby się nie kręcił cały dzień bezsensu.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house
Dnia 19.05.2013 o 22:45, davero napisał:

Czyli nie usuwać nic :12_slight_smile: nie da się dać swoich katalogów ? Zostawić co zainstalował serwer ? 

możesz jaśniej ? nie rozumiem na razie co gdzie dać ?

musisz ustawić uprawnienia...

zik2gy.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

a jak mam podpiac do kompa nas bezpośrednio jak to się ustawia ?

Kabel w kabel zmieniając adresację IP z dhcp na statyczną (czyli recznie ustawić na każdej karcie sieciowej jak i w qnapie)

Wysyłane z mojego GT-I9300 za pomocą Tapatalk 2

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

ehhh chyba pod linuxem sie tego nie da przezucic . Wrzuciłem 3tb danych. Wkladam dysk do nasa i cyrk dysk non stop pracuje mieli, glosno szkoda gadac . Wejsc przez qfindera graniczy z cudem taki zamulony teraz. Nie wiem co robic, Czy sformatowac go i poswiecic mu tydzien na wrzucanie danych po kablu. Wtedy bylo wszystko OK.

 

 

The file system is not clean It is suggested that you run "check disk" takie info dostaje teraz pow sadzeniu dysku po przegraniu danych z pod linuxa

 

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

mam propozycję, docelowy dysk umieść w qnapie, sformatuj na ext4, zrób sprawdzenie systemu plików. następnie utwórz folder, nadaj uprawnienia 777 (zapis wszystkim), wyłącz nasa, podłącz dysk do peceta z linuxem i przerzuć ok 10-20GB do utworzonego wcześniej folderu (nigdzie indziej). ponownie włóż do qnapa i zobacz co się dzieje. jak ok to przerzuć resztę danych i ognia :) pamiętaj o wyłączeniu serwera multimediów (gdyż zamulanie może być spowodowane indeksowaniem biblioteki jeśli wrzucasz jakieś filmy). po przekopiowaniu danych zrób ponowne sprawdzanie systemu plików i porozrzucaj dane po folderach wg uznania ale przez wewnętrznego managera plików qnap. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

mam propozycję, docelowy dysk umieść w qnapie, sformatuj na ext4, zrób sprawdzenie systemu plików. następnie utwórz folder, nadaj uprawnienia 777 (zapis wszystkim), wyłącz nasa, podłącz dysk do peceta z linuxem i przerzuć ok 10-20GB do utworzonego wcześniej folderu (nigdzie indziej). ponownie włóż do qnapa i zobacz co się dzieje. jak ok to przerzuć resztę danych i ognia :) pamiętaj o wyłączeniu serwera multimediów (gdyż zamulanie może być spowodowane indeksowaniem biblioteki jeśli wrzucasz jakieś filmy). po przekopiowaniu danych zrób ponowne sprawdzanie systemu plików i porozrzucaj dane po folderach wg uznania ale przez wewnętrznego managera plików qnap. 

ano wlasnie robie to drugi raz tym razem dalem ext3 :) (na ext4 bylo to samo, mianowicie nie widzi mi przez ftp folderow wrzuconych, mieli ostro dyskiem (moze cos indexuje) i tak samo jak ostatnio pod ext4 nie dziala foto station music itd.) Z tym, ze wrzucalem do katalogu multimiedia (i moze tutaj jest problem) nie dawalem uprawnien - gdzie sie je konkretnie daje ? bo zrobie format zaloze jeden katalog pod nasem i wrzuce tam wszystko (pierw sprawdze po 20gb)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

w takim razie na pewno się indeksuje. stwórz nowy folder. potem w file manager prawy przycisk - właściwości i tam masz zakładkę

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

zaznacz wszystkie checkboxy i wrzuć dane do niego, potem przerzuć stopniowo do multimedia i poczekaj jak skończy indeksację. u mnie na ds713+ trwało to dobę :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

w takim razie na pewno się indeksuje. stwórz nowy folder. potem w file manager prawy przycisk - właściwości i tam masz zakładkę

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

zaznacz wszystkie checkboxy i wrzuć dane do niego, potem przerzuć stopniowo do multimedia i poczekaj jak skończy indeksację. u mnie na ds713+ trwało to dobę :)

to moze nie formatowac ? moze niech skonczy index ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

to moze nie formatowac ? moze niech skonczy index ;)

up to you :) ja bym to zrobił od początku jak pisałem :) ew wyłącz na razie mulimedia server i zobacz...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

up to you :) ja bym to zrobił od początku jak pisałem :) ew wyłącz na razie mulimedia server i zobacz...

wlacz serwer multimediow dlna w tej chwili mam nie zaznaczone tak samo twonky tez nie zaznaczone. wiec chyba nie bylo, a powiec mi jak ja to wrzuce do katalogu swojego to tez bedzie indexowal tak dlugo ? ten katalog np nowy ? czy dopiero jak wrzuce do multimedia ? zakladam ze robie od poczatku

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

a powiec mi jak ja to wrzuce do katalogu swojego to tez bedzie indexowal tak dlugo ? ten katalog np nowy ? czy dopiero jak wrzuce do multimedia ? zakladam ze robie od poczatku

nie...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

OK jade od nowa :). Powylaczalem wsio multimedia itd dalej indexuje chyba teraz sie tego nie da zatrzymac :). Czyli po formacie mam tez wylaczyc serwer multimediow  ? itunes itd ...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
davero

OK jade od nowa :). Powylaczalem wsio multimedia itd dalej indexuje chyba teraz sie tego nie da zatrzymac :). Czyli po formacie mam tez wylaczyc serwer multimediow  ? itunes itd ...

No i nie wiem co robic :). Dalem nowy katalog wrzucilem dane (część)  i dalej mieli co prawda inaczej całkiem ciszej a panel sterowania śmiga. Jeden problem ftp dalej nie widzi tych plikow ... i nie wiem czy nie poświęcić się po kablu bezpośrednio ... co sądzisz ?

Chyba znalazłem odp. FTP działa czyli indeksowal :), więc chyba będzie spoko i moge ładować resztę :) Pod nasem nie da rady usunąc katalogów wgranych przez system, pod linuxem tak, a powiec mi co by się stało jakbym wywalił katalogi i dał np swoje ? wywali mi sie nas? Myślę, że nie będę ruszał, ale pytam z ciekawości :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house

Pod nasem nie da rady usunąc katalogów wgranych przez system, pod linuxem tak, a powiec mi co by się stało jakbym wywalił katalogi i dał np swoje ? wywali mi sie nas? Myślę, że nie będę ruszał, ale pytam z ciekawości :)

 

:/ zostaw i nie ruszaj :)

problem został rozwiązany.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Podobna zawartość

    • glorifyday
      Przez glorifyday
      Po raz kolejny robi mi sie ciasno na moim DS-713+ i choc generalnie jestem z niego na maksa zadowolony, trzeba by sie zastanowic, co dalej z tym fantem.
      Z perspektywy czasu pluje sobie w brode, ze nie kupilem czterodyskowca, teoretycznie moglbym teraz dokupic rozszerzenie, ale rozwazam tez inne opcje.
      Plus jest taki, ze NASy troche poszly do przodu i teraz juz bardziej ekonomiczne modele zapewniaja predkosci wyzsze nawet niz moj DS-713+.
      Minus z kolei - ze przyzwyczailem sie do Synology, ale Synology sie dosc wysoko ceni i nie wiem, czy nie wartoby czegos w zyciu zmienic ;-).
      Zrobilem sobie na morelach wyszukiwanie po czterodyskowcach i w sumie dobrze wyglada cenowo i specyfikacyjnie ten Qnap TS-431P:
      https://www.morele.net/serwer-plikow-qnap-ts-431p-975708/

      Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość. Qnap twierdzi, ze nawet przy szyfrowanym woluminie zapewnia 190 MB/s, co byloby nawet postepem w stosunku do DS-713+. Podoba mi sie tez jeden wielki wiatrak, zamiast dwoch mniejszych, jak w czterodyskowcach Synology.
      No ale mam swoje przyzwyczajenia. Glownie Photo Station. Czy przesiadka na Qnap moze mnie bolec?
      Co to w ogole za firma jest? Synology to AFAIK Tajwan. A Qnap?
    • bischop
      Przez bischop
      Hi
      On my router:
      Tomato v1.28.0000 MIPSR2-2.4-123 K26 USB AIO ======================================================== Welcome to the Netgear WNR3500L v2 [TomatoUSB] # uname -a Linux unknown 2.6.22.19 #4 Wed Oct 29 11:33:28 CET 2014 mips GNU/Linux got problem with DDoS attack. From time to time - usually every day between 6 p.m. - 01:00 a.m. - somebody is attacking. I`m not sure he is attacking from only one IP address or many.
      I got no proper rules for my iptables and i`m not sure exacly how to defend from this kind of attack.
      I think this kind of attack is not on TCP but UDP protocol. Why? becouse i think somebody is trying to DDoS my TeamSpeak v3 server behind that router. If TeamSpeak is turned off - there are not DDoS attack at all, my router is alive and not under heavy traffic.
      Using iptables && conntrack got a problem, becouse my iptables rules are not accepted becouse i got no conntrack :
      # iptables -t mangle -A PREROUTING -m conntrack --ctstate INVALID -j DROP iptables v1.3.8: Couldn't load match `conntrack':File not found Try `iptables -h' or 'iptables --help' for more information.  
       
       
      That is weird becouse i think i got it:
      # lsmod | grep conntrack nf_conntrack_h323 37152 0 nf_conntrack_ipv6 14176 3 # modprobe -l | grep conntrack /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_h323.ko /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_proto_gre.ko /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_sip.ko /lib/modules/2.6.22.19/kernel/net/ipv6/netfilter/nf_conntrack_ipv6.ko /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_ftp.ko /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_pptp.ko /lib/modules/2.6.22.19/kernel/net/netfilter/nf_conntrack_rtsp.ko So if i got it - i dont know how to load this module for IPv4.
      # ll -a /lib/modules/2.6.22.19/kernel/net/ipv4/ drwxr-xr-x 3 root root 191 Oct 29 2014 ./ drwxr-xr-x 9 root root 105 Oct 29 2014 ../ -rw-r--r-- 1 root root 7704 Oct 29 2014 ah4.ko -rw-r--r-- 1 root root 9288 Oct 29 2014 esp4.ko -rw-r--r-- 1 root root 9160 Oct 29 2014 ipcomp.ko drwxr-xr-x 2 root root 593 Oct 29 2014 netfilter/ -rw-r--r-- 1 root root 5344 Oct 29 2014 tcp_vegas.ko -rw-r--r-- 1 root root 5176 Oct 29 2014 tunnel4.ko -rw-r--r-- 1 root root 3284 Oct 29 2014 xfrm4_mode_beet.ko -rw-r--r-- 1 root root 2388 Oct 29 2014 xfrm4_mode_transport.ko -rw-r--r-- 1 root root 3292 Oct 29 2014 xfrm4_mode_tunnel.ko -rw-r--r-- 1 root root 3956 Oct 29 2014 xfrm4_tunnel.ko  
       modprobe -a /lib/modules/2.6.22.19/kernel/net/ipv4/  <doesnt exist nf_conntrack_ipv4.ko>
       
       
      So my question is how to load conntrack ipv4 to get iptables working with it for udp?
      How to set proper rulez for droppig udp traffic by iptables?
      How to configure my router to defend that DDoS?
       
    • Anon
      Przez Anon
      Witam, aktualnie głowie się w jaki sposób mogę wykonać backup z zewnętrznego serwera VPS (najlepiej po sftp/ftp) bezpośrednio na NAS QNAP. Czy jest jakieś gotowe rozwiązanie? Próbowałem przebrnąć przez Hybrid Backup Sync jednak z tego co widzę to jest taka możliwość, ale tylko w odwrotną stronę (z QNAP na zewnętrzny serwer). Czy jest jakaś opcja w systemie QNAPA, która daje taką możliwość, czy trzeba "kombinować" po swojemu?
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Więcej informacji zawiera nasza Polityka prywatności