Skocz do zawartości
StachoF

RT-AC68U uszkadzanie plików w trakcie kopiowania USB

Oceń temat:

Rekomendowane odpowiedzi

StachoF

Witam

 

Mam taką prośbę do wszyskich testerów testujących prędkość zapisu na dyski podłączone do portów USB aby po przekopiowaniu plików w szczególności w formacie iso najlepiej większych gabarytów albo całego katalogu z obrazami płyt porównali sumy kontrolne oryginałów i kopii i podzielili się swoimi spostrzeżeniami.

 

Temat chciałbym poruszyć gdyż jestem po wymianie routera RT-AC68U który miał przypadłość uszkadzania niektórych plików w trakcie kopiowania z komputera na dyski USB jak również w trakcie kopiowania pomiędzy dyskami.

Reklamacja przebiegła bez większych problemów, otrzymałem nowy egzemplarz który niestety zachowuje się tak samo jak poprzedni czyniąc zniszczenie.

Testowane na dyskach HDD pamięciach flash z włączoną opcją redykcji zakłóceń ja i wyłączoną.

Jeden egzemplarz można przyjąć jako pech, drugi no może jako pdwójny pech gorzej jeżeli trzeci będzie robił to samo.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

porównali sumy kontrolne oryginałów i kopii i podzielili się swoimi spostrzeżeniami

@StachoF - sprawdzę i dam znać

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Idanit


porównali sumy kontrolne oryginałów i kopii i podzielili się swoimi spostrzeżeniami.

Napisz jakim programem robisz to porównanie. Ja sprawdziłem dwa pliki .mkv (ok 10GB każdy), programem MD5 Checksum Tool i sumy się zgadzają, nie mam niestety nic .iso

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

MD5 Checksum Verifier do testowania calych katalogów i HashTab 5.1.0.23 rozszerzenie do exploatora window na pojedyńcze pliki.

MKV nie sprawdzałem postaram się w wolnym czasie zobaczyć jak z tymi plikami wygląda.

 

Dodam że nie wszystkie pliki się uszkadzają, często udaje się przekopiować bez błędów a przy katalogach tylko niektóre pliki są uszkodzone.

 

O własnie skończyłem testowanie mkv 11GB niestety znowu róznice w sumach są, w zasadzie widzę że wymieniony model częściej uwala pliki niż pierwszy egzemplarz.

Edytowane przez StachoF

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Idanit

Ok... wyszukałem na kompie jakieś stare pliki .iso (ok 4.3GB). Też wszystkie sumy kontrolne się zgadzają.


Jeden egzemplarz można przyjąć jako pech, drugi no może jako pdwójny pech
Nie chce mi się wierzyć w taki zbieg okoliczności. Podejrzewam, że problemem jednak nie jest tu ruter. Ale musisz podać więcej informacji, na temat sprzętu i testów jakie robiłeś, że podejrzewasz ASUSA.
  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Dzisiaj niestety muszę kończyć do pracy czas się zbierać na nocną zmianę, jutro postaram się opisać bardziej szczegółowo co i jak.

A ta na szybkiego testowane na dwóch komputerach laptop i stacjonarka dyski wd elements 2T 2 sztuki USB 2.0 wd MyBook 2T USB 3.0 peny emtec 32GB USB 3.0 emtec 8GB USB 2.0.

Nigdy nie bylo problemów z tymi dyskami podłączonymi bezpośrednio do kompów ja i do routera TP-Link Archer C7 którego ASUS miał zastapić z uwagi nalepsze prędkości portów USB i może to jest właśnie przyczyną niestety pomoc techniczna również nie bardzo może pomóc dlatego szukam informacji na forum.

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

kilkakrotnie wgrałem i usunąłem przykładowe pliki (zarówno jako pojedynczy jak i w katalogu) z dwóch różnych komputerów - nie zanotowałem żadnych zmian

# MD5 checksums generated by MD5summer (http://www.md5summer.org)
# Generated 2014-05-19 18:03:26

040ca835c550ce8e48d9a312405b0bee *testfile4GB.iso

2014-05-19_181306.png

# MD5 checksums generated by MD5summer (http://www.md5summer.org)
# Generated 2014-05-19 18:21:16
4dd89d32979b9fc9e8a5abf879cc9b43 *00000.m2ts

2014-05-19_183948.png

uruchom to narzędzie i daj znać czy masz już ustawione taktowanie pamięci na wyższy zegar :

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Pamieć ustawiona na wyższy zegar.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

trudno mi coś wywnioskować. sprawdziłem i działa w porządku. stawiałbym raczej na któregoś z pecetów. masz jakiegoś switch'a po drodze ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Switcha nie ma co do pecetów żadnych problemów z nimi nigdy nie bylo, tak jak pisałem wcześniej z TP-linkiem działało wszstko jak należy ale może, postawię system na nowo bez zadnych dodatków może tam tkwi problem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

zobacz czy na karcie sieciowej nie masz włączonej opcji Jumbo Frame. Nie wiem czy ten tryb jest domyślnie w AsusWRT włączony czy też nie.

kolejna możliwość to wgranie Tomato lub DD-WRT i sprawdzenie czy na alternatywnym sofcie dzieje się to samo.

 

 

 

Pamieć ustawiona na wyższy zegar.

 

i tym samym straciłeś możliwość włączenia trybu turbo, dzięki której mogłeś podkręcić procesor do wartości 1GHz.

Edytowane przez shibby

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

i tym samym straciłeś możliwość włączenia trybu turbo, dzięki której mogłeś podkręcić procesor do wartości 1GHz.

obecnie sprzedawane modele mają to "out-of-box" i tool mówi, że nie ma potrzeby zmiany.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

true, ale przed odpaleniem toola nie było wiadomo jaką wersję "poreklamacyjną" dostał kolega. Jak pamiętam gdy odpali się tool na starszym routerze to nie zapyta czy zrobić upgrade, tylko zwyczajnie go robi. Tak więc powrotu nie ma. Pewniejszym sposobem jest więc próba włączenia turbo mode i sprawdzenia jak się router zachowa.

Edytowane przez shibby
  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

zobacz czy na karcie sieciowej nie masz włączonej opcji Jumbo Frame. Nie wiem czy ten tryb jest domyślnie w AsusWRT włączony czy też nie.

kolejna możliwość to wgranie Tomato lub DD-WRT i sprawdzenie czy na alternatywnym sofcie dzieje się to samo.

i tym samym straciłeś możliwość włączenia trybu turbo, dzięki której mogłeś podkręcić procesor do wartości 1GHz.

 

Aktualnie zainstalowałem czystą 8-ke przewaliłem ponad 100 GB na nowy dysk MyBook 3TB trochę czasu zejdzie zanim się przetestuje jak sie skończy to dam znać.

Opcje Jumbo Frame na karcie i w routerze są wyłączone, w laptopie jej nie widzę, jeżeli dalej będzie się sypać to napewno załaduje twoje Tomato.

Co do taktowania pamiąci oba egzemplarze miały już wyższe taktowanie od nowości.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

Co do taktowania pamiąci oba egzemplarze miały już wyższe taktowanie od nowości.

 

no to szczęście w nieszczęściu :) Widać mój Rt-AC68U z aktywnym Turbo Mode to już egzemplarz muzealny, którego ze świeczką szukać :D

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Jak narazie na czystej 8-ce 100GB przeszło bez szfanku teraz trzeba poinstalować sterowniki itp i zobaczymy jak się będzie zachwywac, może coś mialem skopane w w7 ciekawostka.

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Jak narazie na czystej 8-ce 100GB przeszło bez szfanku

światło w tunelu :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Stery, aktualizacje antyviry itp poinstalowane, poraz kolejny puszczona paczka 100GB przeszła bez problemów, wygląda na to że problem rozwiązany.

Dzięki wszystkim za sugestie temat uważam narazie za zamknięty.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Niestety problem powrócił w trakcie kopiowania na drugi dysk USB 2.0 oraz w trakcie przekopiowywania z dysku USB 3.0 na USB 2.0 ręce opadają.

Jeszcze sprawdzę w grugą stronę.

Pora chyba wgrać Tomato i zobaczyć co się będzie działo.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

czekam z niecierpliwością na info zwrotne :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Narazie pusciłem kopiowanie z dysku na dysk z routerem podpiętym pod starego pentiuma IV trochę to zejdzie ale chcę zobaczyć co wyjdzie a potem zmieniamy soft.

Jeśli można prosić o szybki tutorial i ewentualne problemy przy wgrywaniu bo już mam dośc ślęczenia przed kompem od soboty.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

@StachoF Asus FW restore z pakietu :

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

po flashowaniu przycisk WPS i czekasz aż się router odezwie 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

Na pentium IV i XP tak samo uszkodzonych kilka plików.

Tomato załadowany kopiowanie puszczone na dysk usb 3.0 z kompa tylko coś te prędkości nie zabardzo, skacze w okolicach 20MB/s +- 5 coś cienko, nic trzeba czekać.

Edytowane przez StachoF

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Tomato załadowany kopiowanie puszczone na dysk usb 3.0 z kompa tylko coś te prędkości nie zabardzo, skacze w okolicach 20MB/s +- 5 coś cienko, nic trzeba czekać.

Hmm :/ że tak chrzakne :/

tapniete z telefonu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

szybka prędkość i uwalone pliki czy wolniej ale poprawnie? Z dwojga złego co wybierasz?

 

Przeszedłeś już tyle, że priorytetem powinno być dla ciebie by w ogóle zapis był poprawny, prawda?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house
Dnia 22.05.2014 o 12:31, shibby napisał:

szybka prędkość i uwalone pliki czy wolniej ale poprawnie? Z dwojga złego co wybierasz?

zdecydowanie poprawność zapisu :12_slight_smile:

 

Dnia 22.05.2014 o 12:31, shibby napisał:

priorytetem powinno być dla ciebie by w ogóle zapis był poprawny, prawda?

dokładnie, aczkolwiek przez ostatnie 2 dni (tak dla sportu aby sprawdzić) przerzuciłem na dysk w asusie tak ca 40-50GB i wszystkie sumy kontrolne były poprawne więc coś mi tu nie gra. Rzeczywiście może coś jest nie tak z kolejnym egzemplarzem, albo przyczyny trzeba szukać poza nim. poprawnie to dla mnie jest możliwości sprzętu oraz poprawny zapis :12_slight_smile:

@StachoF -

tutaj

Dnia 20.05.2014 o 14:42, StachoF napisał:

MyBook 3TB

masz NTFS ?

 

a tu ? 

Dnia 19.05.2014 o 16:48, StachoF napisał:

peny emtec 32GB USB 3.0 emtec 8GB USB 2.0.

FAT32 ?

próbowałeś zmienić system plików na ext2/3 na penach lub ext4 na dysku WD i sprawdzić ? kopiowanie przez exploratora windows, total commander, xcopy, rsync - jakim narzędziem to robisz?

sprawdź 

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

i obserwuj source i target crc:

teracopy_full.png

często używam tego toola na serwerach z server2008/2012 i nigdy nie miałem problemu. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

szybka prędkość i uwalone pliki czy wolniej ale poprawnie? Z dwojga złego co wybierasz?

 

Przeszedłeś już tyle, że priorytetem powinno być dla ciebie by w ogóle zapis był poprawny, prawda?

 

Po to kupowałem RT-AC68U żeby bylo szykbo i poprawnie, do wolno mam TP-Linka Archer C7 10-12 MB/s

 

 

house

MyBook 3TB - NTFS

peny emtec 32GB USB 3.0 emtec 8GB USB 2.0 również NTFS,kopiowanie przez exploratora windows

Raz puściłem pena 8GB na ext3 ale też się sypło

TeraCopy wygląda ciekawie właśnie zapuściłem 100GB z kompa na dysk USB 3.0 potem to samo z dysku na dysk i zobaczymy czy wolniej znaczy lepiej.

 

Dzisiaj trochę lepiej idzie średnio 30 MB/s może wtyczka cos nie stykała.

Edytowane przez StachoF
  • Lubię 2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
shibby

10-12 a 20-25MB/s to jednak spora różnica prawda? Skoro chciałeś mieć szybki storage to trzeba było kupić NASa, byłoby szybciej i taniej. Pamiętaj, że to jednak w dalszym przypadku jest router, a funkcja NASa to tylko dodatek. Jeżeli obciążysz procesor np. szybkim łączem lub wifi to wydajność USB diametralnie spadnie. W końcu za wszystko odpowiedzialny jest ten sam procesor.

  • Lubię 2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
StachoF

10-12 a 20-25MB/s to jednak spora różnica prawda? Skoro chciałeś mieć szybki storage to trzeba było kupić NASa, byłoby szybciej i taniej. Pamiętaj, że to jednak w dalszym przypadku jest router, a funkcja NASa to tylko dodatek. Jeżeli obciążysz procesor np. szybkim łączem lub wifi to wydajność USB diametralnie spadnie. W końcu za wszystko odpowiedzialny jest ten sam procesor.

Pewnie masz rację czlowiek przecież uczy się na błędach, w pszyszłości coś się wykombinuje. Narazie na domowe warunki miał wystarczyć, byle by nie psuł bo już mam dość patrzenia na CRC pograło by się w coś.

 

 

Dzień następny

Po nocnym kopiowaniu sytuacja wygląda następująco:

Kopiowane 100GB za pomocą TeraCopy - fajny bo sam robi weryfikację

Win8 z koputera na dysk USB 3.0 - bez błędów

Win8 z dysku USB 3.0 na dysk USB 2.0 - bez błędów

Win7 Laptop z dysku USB 3.0 na dysk USB 2.0 -bez błędów

 

Teoretycznie wychodzi na to że problem tkwi w firmware Asusa skoro na Tomato działa, tylko dlaczego problemy występują tylko u mnie.

 

Potwierdzenie

Powróciłem do najnowszego firmware Asusa, kopiowanie TeraCopy z dysku na dysk i ponownie błędy sum kontrolnych.

Edytowane przez StachoF
  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Podobna zawartość

    • betelgeza
      Przez betelgeza
      Witajcie Koledzy,
      Stanowisko Supportu Asus Polska na dziś 22.05.2014 jest takie, że aktualne oprogramowanie RT-AC68u nie wspiera żadnego modemu działającego o transmisję LTE.
      Tak się jednak składa, że przynajmniej jeden modem LTE działa i to bardzo sprawnie. Dlatego chciałbym w tym temacie zachęcić użytkowników, którym udało się odpalić LTE na wspomnianym routerze do podzielenia się informacją na temat modelu modemu oraz wersji oprogramowania routera.
      Z pewnością te dane ułatwią poszukującym informacji skompletowanie działającego zestawu.
      Na pierwszy ogień przetestowany przeze mnie oraz użytkownika @The Dino modem Huawei:
      Huawei E3272 HILINK   (wersja firmware routera: 3.0.0.4.374_5656-g8d0a991) Huawei E1820 (3G)   (wersja firmware routera: ?) Huawei E3276 (LTE)   (wersja firmware routera: ?) pozdrawiam b.
    • OpenITbot
      Przez OpenITbot


      Zobacz plik ASUS RT-AC68U Firmware
      ASUS RT-AC68U Firmware
      Dodający OpenITbot Dodano 2014.02.14 Kategoria ASUS  
    • kamil2234
      Przez kamil2234
      Cześć chcę się pochwalić prototypem ramki LCD współpracującej z moim routerem Asus RT-AC68U z firmware Merlina.
      Myślę, że jest to bardzo fajny gadżet na domowe biurko dla takich jak my:

      Jako pakiet sterujący wyświetlaczem używam LCD4LINUX.  Jest to dość wygodne, gdyż jest wiele widgetów pokazujących użyteczne informacje o pracy routera. Dostępne informacje to np. aktualnie zużywany traffic połączenia internetowego,  informacje o sieci wifi , jakość zasięgu modemu LTE huawei, zew adres ip, informacje o nieodebranych email itd. Oprogramowanie LCD4LINUX jest już dostępne w pakietach optware i entware dla dużej ilości routerów. Jak widać nawet mój  router ze stosunkowo nową architekturą  ARM7  doczekał się tego pakietu. Podzespoły z jakiego zmontowałem cały zestaw można kupić na Allegro. Jeśli wyświetlacz ma działać pod usb to potrzebujecie konwertera, który trzeba przylutować do 16 pinowego złącza wyświetlacza LCD HD44780. Ja swoje czteroliniowe wyświetlacze alfanumeryczne kupowałem w hurtowni Telmal (39 zł) – dość drogo. Jeśli natomiast chcecie podłączyć swój wyświetlacz pod  Raspberry PI lub Arduino to wówczas potrzebujecie konwertera  LCD2USB I2C/IIC dla wyświetlaczy LCD HD44780 (koszt około 10 zł) Kolejnym elementem jest ramka plexi, którą sam zaprojektowałem i zamówiłem u jednego producenta w dużym nakładzie.  Niestety nikt nie chciał się zdecydować, aby wyprodukować kilka sztuk z uwagi na zbyt niską wartość zamówienia.  Gdyby ktoś z Was szukał to dawajcie znać na priv albo zajrzyjcie na allegro, bo cały nadmiar wystawiłem do sprzedaży. Ze względu na dużą ilość oprogramowania do tego wyświetlacza można naprawdę zrobić z niego użyteczne centrum informacji. 
      Oprócz typowego zastosowania przy routerach można go podłączyć do:
      dysków sieciowych Synoglogy lub Qnapa (informacje takie jak obciążenie dysku, ilość wolnego miejsca na dysku, informacje o nieodebranych połączeniach przychodzących z centrali telefonicznej Asterisk wbudowanej w dysk sieciowy itd.) Raspberry pi – pokazuje informacje o aktualnie oglądanych programach na Kodi, aktualnie słuchane stacje radiowe, informacje z czujników  temperatury ds1820b lub czujnika wilgotności i temperatury DHT22 oraz wszystko to, co dostępne jest w pakiecie LCD4LNIUX. W planach mam też zamiar przetestować czujniki ciśnienia, czujniki przepływu prądu w gniazdkach, czy wyświetlać informacje o problemach smart domu. kolejna fajna inspiracja to program aida64, który może pokazywać informacje o parametrach naszego komputera PC/Laptopa – narzędzie szczególnie przydatne do overclockingu . nie zapomniałem również o Dreamboxie, który jest kultowym dekoderem pozwalającym oglądać wiele programów z polskich platform cyfrowych. Niestety jak wszyscy wiemy w popularnym DM 800 HD wyświetlacz jest dość mały, a na dodatkowym wyświetlaczu można pokazać np. informacje EPG. Jeśli więc chcemy więcej informacji o aktualnie oglądanych programach można zaadoptować właśnie taki wyświetlacz alfanumeryczny. Tak jak już wspomniałem jednym z zastosowań tego wyświetlacza, których mam klika jest informowanie mnie o tym, co się dzieje w routerze. Na pewno większość z Was zastanawia się jak tym sterować.  Generalnie sprawa jest dość prosta gdyż po instalacji pakietu  LCD4LINUX wystarczy stworzyć plik konfiguracyjny, który będzie kopiowany przy stracie routera do lokalizacji /etc/lcd4linux.conf.
      Lcd4linux instalujemy za pomocą komendy:
      (dla menadżera pakietów optware)
      Ipkg install Lcd4linux  (dla menadżera pakietów entware)
      Opkg install Lcd4linux Przykład pliku konfiguracyjnego macie tu:

      Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość. W przypadku wyświetlacza HD44780 konfiguracja jest banalna.
      Przykładowa zawartość pliku lcd4linux.conf dla wyświetlacza  HD44780 z konwerterem lcd2usb.
      Jeśli będziecie mieć problem z wykrywaniem urządzenia to trzeba sobie zainstalować usb
      Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość. opkg install usbutils (ipkg/opkg używamy w zależności od  zainstalowanego na routerze menadżera pakietów ja dalej będę pisać na przykładzie  Entware)
      Wydajemy wówczas polecenie lsusb i szukamy  coś takiego jak Bus XXX.  U mnie to numer  003 - u Was może być to inny numer w zależności od waszego routera lub np stosownego huba usb, czy ilości podłączonych urządzeń. Trzeba wpisać ten numer w config w sekcji Display LCD2USB. Dodam też, że w przypadku podłączenia wyświetlacza pod HUB usb tracicie możliwość kontrolowania jasności ekranu.  Należy o tym pamiętać.  Jeśli Wasze urządzenie posiada port usb 3.0 to zapewne ma wydajność prądową około 0.9 A, przy napięciu 5V.  Jest to prawie dwa razy więcej niż moc jaką daje usb 2.0. Jeśli nie stosujecie zbyt dużo aktywnych urządzeń takich jak dyski 2,5", bez własnego zasilania to spokojnie wystarczy Wam zwykły pasywny rozdzielacz USB 3.0. Sam wyświetlacz zużywa max 100mA więc jeśli macie zestaw pendirve usb, modem LTE i taki wyświetlacz to nie zabijecie sobie routera. Jak mace usb 2.0 to radzę stosować aktywne rozdzielacze usb z zewnętrznym zasilaczem.
      admin@RT-AC68U-7E68:/tmp/home/root# lsusb Bus 003 Device 003: ID 0403:c630 Future Technology Devices International, Ltd lcd2usb interface Bus 002 Device 008: ID 8644:800e Bus 002 Device 009: ID 12d1:14dc Huawei Technologies Co., Ltd. Bus 002 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub Bus 001 Device 002: ID 05e3:0617 Genesys Logic, Inc. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub W przypadku openwrt trzeba pamiętać o tym, że podczas startu routera nasz katalog etc znajduje się w pamięci ram i za każdym razem należy kopiować do niego plik konfiguracyjny oraz ustawić prawa do pliku.
      Wchodzimy więc w katalog, aby przygotować skrypty które będę to robić po starcie systemu.
      cd /jffs/scripts Następnie tworzymy plik konfiguracyjny za pomocą edytora vi lub nano. Jeśli nie mamy nano to instalujemy go:
      opkg install nano Następnie tworzymy plik konfiguracyjny, który będziemy potem kopiować do katalogu /opt/etc:
      nano lcd4linux.conf Wklejamy do otwartego pliku lcd4linux.conf zawartość pliku konfiguracyjnego.
      Następnie za pomocą nano edytujemy plik post-mount
      nano post-mount Na jego  końcu dopisujemy takie linijki (opisuję to wyłącznie dla Entware w optware jest inaczej)
      Kod do dodania:
      sleep 2 cp /jffs/scripts/lcd4linux.conf /opt/etc/lcd4linux.conf chmod 600 /opt/etc/lcd4linux.conf sleep 40 /opt/etc/init.d/rc.unslung restart Jak widzicie kopiujemy do /opt/etc a nie do /etc/
      Jeśli chcecie sobie odpalić LCD4LINUX w trybie testowym to bardzo ważne jest skopiowanie configa również do /etc/lcd4linux.conf i oczywiście trzeba zmienić prawa do pliku na 600
      Z pomocą przychodzą nam dwa polecania:
      cp /jffs/scripts/lcd4linux.conf etc/lcd4linux.conf chmod 600 /etc/lcd4linux.conf Testowanie LCD4linux wykonujemy w następujący sposób:
      lcd4linux -Fvv lub
      lcd4linux -F -f /etc/lcd4linux.conf Na koniec podpowiem, że sterowanie jasnością wyświetlacza można osiągnąć poprzez zmianę wartości  w zakresie od 001 do 255
      Brightness Jeśli chcecie sobie przyciemniać ekran tak, aby nie świecił w nocy zbyt jasno można np. stosować zadania automatyczne CRON, które skopiują config do katalogu /opt/etc/, zmienią prawa do pliku, a na koniec zrestartują lcd4linux.
      To jak Ja to zrobiłem może nie do końca jest poprawnie, ale podzielę się z Wami skryptami. Wadą tego skryptu jest to, że w przypadku gdy zrestartujecie router po godzinie 22:30, to będzie Wam świecił jasnością do następnego dnia do 22:30. Pewnie go poprawię i kiedyś zaktualizuję.
      Edytujemy zawartość pliku services-start wpisując:
      nano services-start i następnie gdzieś na początku za tymi dwoma linijkami
      #!/bin/sh script="/opt/etc/init.d/rc.unslung" dopisujemy zadania automatyczne CRON, które będą zmieniać jasność o określonych godzinach. Dzięki temu codziennie o 22:30 wyświetlacz będzie stawać się ciemny, a o 7:30 znowu się rozjaśni.
      cru a darklcd "30 22 * * * /jffs/scripts/dark_copylcd4linux.sh" cru a lightlcd "30 7 * * * /jffs/scripts/light_copylcd4linux.sh" Tworzymy skrypty przeładowujące konfigurację, które są wywoływane z CRON.
      nano light_copylcd4linux.sh Przykładowa zawartość pliku light_copylcd4linux.sh, który musicie sobie utworzyć:
      #!/bin/sh cp /jffs/scripts/lightlcd4linux.conf /opt/etc/lcd4linux.conf chmod 600 /opt/etc/lcd4linux.conf /opt/etc/init.d/S91lcd4linux restart analogicznie robimy dla drugiego skryptu ładującego drugi config . Za pomocą edytora  nano  tworzymy plik dark_copylcd4linux.sh i wklejamy zawartość poniżej:
      #!/bin/sh cp /jffs/scripts/darklcd4linux.conf /opt/etc/lcd4linux.conf chmod 600 /opt/etc/lcd4linux.conf /opt/etc/init.d/S91lcd4linux restart Należy też stworzyć zawartość plików  darklcd4linux.conf oraz lightlcd4linux.conf w katalogach /jffs/scripts/ kopiując cały config lcd4linux.conf.  W zależności od preferencji ustawiacie tam oczekiwany poziom jasności wyświetlacza edytując wartość:
      Brightness 100 Aha zapomniałem jeszcze dopisać jak ma wyglądać poprawna zawartość pliku startującego demona S91lcd4linux
      Za pomocą edytora nano otwieramy aktualny plik i usuwamy wszystko
      nano /opt/etc/init.d/S91lcd4linux wklejamy poniższą zawartość:
      #!/bin/sh ENABLED=yes PROCS=lcd4linux ARGS="-f /opt/etc/lcd4linux.conf" PREARGS="" DESC=$PROCS PATH=/opt/sbin:/opt/bin:/opt/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin . /opt/etc/init.d/rc.func Na koniec restart routera. Jak coś pominąłem  lub Wam nie działa to  zgłaszajcie Dajcie też znać jak się Wam podoba ramka.

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Więcej informacji zawiera nasza Polityka prywatności