Skocz do zawartości
branetre

Jeden dysk w grupie dysków zdegradowany - RAID1

Oceń temat:

Rekomendowane odpowiedzi

branetre

Mam sobie serwer DS214PLAY raptem miesiąc a w nim 2 dyski WD30EFRX od czasu jak postawiłem dsm 5.0 pojawił się problem z jednym dyskiem Co kilka dni mam alarm pikania i komunikat że jeden dysk w grupie raid nie działa prawidłowo i że raid został zdegradowany. Zawsze jest to ten sam dysk i nawet po ponownej instalacji z zamianą miejscami dysków zawsze wskazywany jest ten sam. SMART nic nie powiedział i twierdzi że dysk jest sprawny. Wypiołem dysk i pod kompem potraktowałem go Viktorią Też jest ok. Nie mam pomysłu co może być nie tak Awarię synka wykluczam bo na innych dyskach śmiga aż miło. Może nowy DSM coś inaczej formatuje dyski Dziwi mnie fakt że dysk jest formatowany od 64 sektora a nie od 256 :/

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

@ zapytaj @Jabol - ma wyrobione zdanie na temat tych dysków :)

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
branetre

@ zapytaj @Jabol - ma wyrobione zdanie na temat tych dysków :)

Masz do niego inny niż pw kontakt ? Ostatnio był 18.03.2014 :/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Dostał powiadomienie, że wspomniałem o nim w poście więc jak się pojawi to odpowie.

Forum synology ma zatrzęsienie tematów z tym problemem :/ używasz hibernacji dysków ?

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
branetre

Tak i też się zastanawiałem nad ty czy to może być temu winne Zawsze mam komunikat przy degradacji że nie można było zainicjować dysku nr 1 Tylko pytanie czy problemem jest nowy DSM 5.0 czy sam sposób w jaki odbywa się start dysków Ponoć w tych redach jest synchronizowany mechanizm rozruchowy i tylko jedna elektronika z dysku pierwszego steruje silnikami obu dysków.

Zastanawiam się jeszcze nad tą opcją Miałem to włączone i może to temu ?

openit_1395395190__zaawansowane.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Zastanawiam się jeszcze nad tą opcją Miałem to włączone i może to temu ?

wyłączyłem to rok temu i od tamtej pory nie włączałem, nawet na DSM5. Sprawdź.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
branetre

wyłączyłem to rok temu i od tamtej pory nie włączałem, nawet na DSM5. Sprawdź.

Wychodzi na to że to to :

Mar 19 23:36:41 home kernel: [132697.636873] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Mar 19 23:36:41 home kernel: [132697.643998] ata1.00: failed command: FLUSH CACHE EXT
Mar 19 23:36:41 home kernel: [132697.649064] ata1.00: cmd ea/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Mar 19 23:36:41 home kernel: [132697.649069]          res 40/00:ff:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Mar 19 23:36:41 home kernel: [132697.662757] ata1.00: status: { DRDY }
Mar 19 23:36:52 home kernel: [132707.688474] ata1: softreset failed (device not ready)
Mar 19 23:36:52 home kernel: [132707.693607] ata1: SRST fail, set srst fail flag
Mar 19 23:39:53 home kernel: [132717.720370] ata1: softreset failed (device not ready)
Mar 19 23:39:53 home kernel: [132717.725498] ata1: SRST fail, set srst fail flag
Mar 19 23:39:53 home kernel: Mar 21 07:09:18 home kernel: [    0.000000] ACPI: RSDP 0009fc00 00024 (v02 INTEL )

Kawałek z /var/log/messages

 

 

EDIT: 14:30

 

Szukalem po logach w sieci i praktycznie związane jest to z nowym jakiem w linuxach Postanowiłem ostatni raz przed wysyłką na GW powrócić do DSM 4.3 Uprzednio formatując oba dyski pod innym urządzeniem. Podkreślam że problem pojawił się pare dni po zainstalowaniu DSM 5.0 Wcześniej nic takiego nie miało miejsca. Pożyjemy zobaczymy.

Edytowane przez lud3ik

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Jabol

Moja opinia o dyskach wd red jest taka że to nic innego jak wd green ze zmienionym softem lub lekko elektroniką. W wd green zdarzało się często że dyski potrafiły wypaść z macierzy przy RAID 5 itp.

 

Ja osobiście mam kiepską opnie o WD bo wszystkie które miałem szybko zdechły.

 

Najlepsze doświadczenia mam z dyskami samsunga no ale ich już nie ma :(

 

Degradacja najczęściej występuje gdy dysk ma za długą korekcje błędu, a to podobno w redach jest zmienione bo są specjalnie przystosowane.... tia....

 

Co do zmiany DSM to bardzo możliwe że to jest tego winą. Mianowicie ostatnio znajomy aktualizował DSM na DS213 a ma na nim monitoring zrobiony. Po aktualizacji nagle się okazało że procek jest w 99% ciągle obciążony i co chwile zrywa połączenia z kamerami. Powrót do wcześniejszej wersji DSM rozwiązał problem.

 

Ale myślę że może być coś na rzeczy bo już czytałem dziś temat gdzie kolesiowi po 2 dniach od instalacji DSM 5 zdegradowało jeden dysk na Seagate ST3000DM001

Edytowane przez Jabol
  • Lubię 2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
branetre

No i problem przestał występować. Mija 4 dzień od czasu degradacji (zdarzało się to co 2-3 dni) Wgrałem wszystkie dane które miałem na backupach i nic się nie stało. Nie wiem czy winne jest nowe oprogramowanie czy może ustawienia hibernacji które też wyłączyłem. Może to też być różnica temperatur dysków (wcześniej miały po 32 stopnie a teraz 37 - zmiana położenia na zamkniętą szafkę poza zasięgiem dzieci). Mam nadzieję że jeżeli winne było dsm 5.0 to to poprawią ... Dziwi mnie jednak że wersja beta chodziła u mnie prawie 8 dni bez problemów.

 

 

 

Edit: Po aktualizacji do Update 1 w dsm 5.0 i wyłączeniu hibernacji problem się nie pojawia Pewnie bolączka tylko tego modelu serwera przy pierwszym stabilnym wydaniu dsm 5.0

Edytowane przez lud3ik
  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Podobna zawartość

    • Hictis1935
      Przez Hictis1935
      Witam,
      posiadam router ASUS RT-AC68U, firmware Merlin 380.68_4 i światłowód 600 Mbit/s.
      Przy podłączeniu kabla WAN bezpośrednio do karty sieciowej uzyskuję gwarantowaną prędkość.
      W momencie poprowadzenie sieci przez router, maksymalne osiągi oscylują w granicach 500 Mbit/s.
      CPU Core 1 osiąga 100%, Core 2 jest prawie nie używany.
      QoS, Bandwitch Monitor, Air Control i inne dodatki są off.  W zakładce info WAN i Lan 1 Gbps.
      Próbowałem różne ustawienia w zakłade Switch Control (Enable Jumbo Frame, Spanning-Tree Protocol, NAT Acceleration ON/OFF) ale to nic nie pomaga.
       
      Udało mi się znaleźć informacje, że niektórzy na tym routerze wyciągają prędkości > 900 Mbit/s.
      Proszę  pomoc, lub sugestie co jeszcze mógł bym sprawdzić aby w pełni wykorzystać możliwości ISP.
    • MasterD23
      Przez MasterD23
      house chciałem już w tym tygodniu kupić synology rt2600ac ,ale trafiłem na ten post i poczytałem sobie trochę. I teraz mam mętlik w głowie. Czy kupić tego synology, czy może ASUS RT-AC86U ?. Ceny w Polsce są podobne. Kilka osób narzekało na zasięg synology.
      A jak kupię w tym sklepie, to jak z gwarancją i polskim FW. ? Czy ten sprzedawca jest ok?  Dodam, że nie posiadam NAS i w najbliższym czasie nie będę miał.
    • no4fly1
      Przez no4fly1
      Mam chyba podobną potrzebę.
      Chciałbym  jednorazowo wykonać kopię zapasową na zewnętrznym  serwerze .
      Z uwagi na dużą ilość danych (zdjęcia) nie chcę tego robić przez  pośredni komputer.
      W moim przypadku to z Qnap  do Synology.
      Do obu serwerów mam  dostęp i odpowiednie uprawnienia.
      Jedyne co znalazłem  to:  Zdalna replikacja ----> z serwera NAS na serwer NAS  ----> Stwórz zadanie replikacji
      I tu mam pytania:
      Czy przy jednorazowej akcji to odpowiedni sposób?
      Jaki nr portu Synology wpisać ? Domyślnie wpisany jest 873 ale podaje że to nieprawidłowy port.
      Na routerze  (przed Synology) mam przekierowane porty: 20, 21, 80, 5000, 5001

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Więcej informacji zawiera nasza Polityka prywatności