Jump to content
house

Tomato-ARM na Asus RT-AC68U

Rate this topic

Recommended Posts

house

Tomato-ARM działa. Cierpi jeszcze na bolączki wieku dziecięcego ale najważniejsze jest, że się uruchamia :D

openit_1393957584__2014-03-04_181829.pngopenit_1394001121__openit_1393957570__20openit_1394001126__openit_1393957577__20

Victek (http://victek.is-a-geek.com/specs.html) szumnie zapowiedział swoją modyfikację kilka miesięcy temu, ale @shibby go ubiegł i jest już w fazie testów :D

  • Like it 1

Share this post


Link to post
Share on other sites
house
You do not have the required permissions to display the content of the code field.

Share this post


Link to post
Share on other sites
shibby

Porównałem na szybko konfigurację board i vlanow i się zgadza z moja. Rozumiem że nadal ci zrywa połączenia?

Jak siade do kompa to przejrze logi

Edited by shibby

Share this post


Link to post
Share on other sites
house

nie tyle zrywa co po flashu sytuacja wygląda tak, że router wstaje ale nie ma komunikacji do niego, interfejsy radiowe leżą - więc po bożemu reset WPS'em.
i tak : po restarcie znów brak komunikacji zarówno po kablu jak i diody od radia nie palą się. wciskam z boku WiFi on/off - podnoszą się radia bo zapalają się diody - i w tym samym czasie pojawia się komunikacja po kablu i działa dhcp.

reset nvram z webgui (pełny) i ponownie restart. po restarcie znów to samo - brak komunikacji zarówno po kablu jak i diody o radia nie palą się. wciskam z boku WiFi on/off - podnoszą się radia bo zapalają się diody.

 

nie ma znaczenia, czy czyszczę nvram z konsoli czy też z webgui. dzieje się dokładnie to samo. 

 

włączam turbo mode. wciskam przycisk LED - restart - nic - nie żyje kompletnie, diody od WLAN się nie palą, nie daje rady podnieść ich przyciskiem pod WPS (ten on/off).

i tyle...

Share this post


Link to post
Share on other sites
shibby

po wyczyszczeniu nvramu router się restartuje i router odlicza 90sek. Pełny restart routera trwa ok 140sek. Tak więc te 90sek licznika to za mało (nie poprawione jeszcze), trzeba odczekać dłużej. Pytanie ile ty czekałeś?

 

Logi, nvram - wszystko wygląda poprawnie. Tak więc jedyne co mi przychodzi do głowy to właśnie ten czas. Wyczyść nvram i odczekaj ok 140-150sek (w sumie 140sek to ma nawet asus ustawione). Diody wifi muszą się zapalić zaraz po wykryciu interfejsów przez sterownik (a w logach widać, że ci wykrywa je popranie).

Share this post


Link to post
Share on other sites
house

Pytanie ile ty czekałeś?

ok 3 minut tak +/- 

Share this post


Link to post
Share on other sites
shibby

no to runęła moja teoria...

Sprawdźmy czy mamy wgraną tą samą wersję. W about na dole jest data kompilacji. Moja to

You do not have the required permissions to display the content of the code field.

Jutro zapiszę swoją konfigurację, wyczyszczę nvram i zobaczę po jakim czasie wstał. Postaram się nagrać filmik.

  • Like it 1

Share this post


Link to post
Share on other sites
house

 

Sprawdźmy czy mamy wgraną tą samą wersję

tę samą. a miałeś inne kompilacje ? 

Edited by house

Share this post


Link to post
Share on other sites
shibby

No wiesz kompilowalem tego po kilkanascie razy dziennie ;) mogło sie więc okazać ze omyłkowo podeslalem ci jakiś inny kompilat.

Share this post


Link to post
Share on other sites
shibby

do katalogu betatest wrzuciłem filmik. U mnie wszystko działa. Po prostu trzeba być cierpliwym między restartami go niektóre mogą trwać nawet 3min. Wifi startuje za każdym razem, pokazałem jak naprawić radio 5GHz by działało na 80MHz. Pokazałem też OC procka.

 

Spróbuj powtórzyć te kroki.

 

btw znalazłem błąd z odtwarzaniem zapisanej konfiguracji. Dokładniej rzecz mówiąc to zapis konfiguracji jest coś niepoprawny i później restore nie potrafi go odczytać. Trzeba robić save przez ssh i odtwarzać go też przez ssh. Wtedy działa.

 

Pozdro

Share this post


Link to post
Share on other sites
house

nagrane programem Mirillis action. Splash otwiera to bez problemu.

obejrzałem i nigdy nie udało mi się osiągnąć takiego efektu. 4x go wgrywałem, resetowałem i  :kupa:

albo mam pecha, albo router dziwny albo dupa ze mnie nie tester :)

Share this post


Link to post
Share on other sites
jacekb1

@house, a tomato odpusciles ? nie dopytuje o szczegoly, ale chyba jest jeszcze sporo problemow do rozwiazania przez @shibby ?

Share this post


Link to post
Share on other sites
house

@house, a tomato odpusciles ?

nie, ale wymaga sprawdzenia wszystkiego.

 

ale chyba jest jeszcze sporo problemow do rozwiazania przez shibby'ego

no właśnie nie :) ale nie mogę nic więcej powiedzieć :)

  • Like it 1

Share this post


Link to post
Share on other sites
jacekb1

no właśnie nie :) ale nie mogę nic więcej powiedzieć :)

 

 

Hehe, i to jest swietna wiadomosc, dzieki :)

  • Like it 1

Share this post


Link to post
Share on other sites
shibby

house apropo OC mamy potwierdzenie od samego merlina

You do not have the required permissions to view the link content.

 

CPU: 1 GHz (through Turbo mode)
DDR: 666 MHz

< Router failed to boot>

 

uzywales narzędzia AC68U DDR Configuration Upgrade Tools ? On podmienia bootloader.

 

Share this post


Link to post
Share on other sites
house

@shibby tak :) 3-4 tygodnie temu :) i co teraz ?

edit/ na starym egzemplarzu tak, na nowym juz nie bo przyszedł z bootladerem nowym który miał już 666MHz.

Share this post


Link to post
Share on other sites
shibby

no i właśnie jak to RMerlin napisał w nowym bootloaderze jest spie**a funkcja OC i nic się na to póki co nie poradzi. Cofnąć bootloadera się nie da a faktycznie wszystkie nowe egzemplarze są już z ramem 666MHz.

 

Ja mam egzemplarz z grudnia z ramem 533 i dlatego działa mi OC. (przynajmniej jedną rzeczy wyjaśniliśmy ;P)

 

a jak w ogóle tomato bez OC? działa ci czy nadal sieć zrywa? Dałem wczoraj tomato-arm kilku osobom (w tym zagranicznym) i pomijając kwestię OC to najpoważniejszy znaleziony problem to niemigające diody USB, więc jest dobrze ;)

 

btw nie wiem czy widziałeś ale jeden ludek z zagranicy wgrał moje tomato (defacto dla asusa) do netgeara 6300v2 i mu wszystko działa :D Myślę więc, że odpalenie tomato na R7000 to będzie pikuś.

Edited by shibby

Share this post


Link to post
Share on other sites
grz3si3k

no i właśnie jak to RMerlin napisał w nowym bootloaderze jest spie**a funkcja OC i nic się na to póki co nie poradzi. Cofnąć bootloadera się nie da a faktycznie wszystkie nowe egzemplarze są już z ramem 666MHz.

hmmm.. to stawiam że mój po wymianie jest też z 666MHz..  

Share this post


Link to post
Share on other sites
house

Ja mam efekt taki jak opisywałem za każdym razem.

Share this post


Link to post
Share on other sites
house

więc co dalej z routerami z nowym bootloaderem ? będzie ich coraz więcej... i te z początku produkcji będą w mniejszości

Share this post


Link to post
Share on other sites
jacekb1

Po przeczytaniu tematu widze, ze borykamy sie z tymi samymi problemami - 666MHz / nie wstawanie softu/radia po flashu itp.

Share this post


Link to post
Share on other sites
house

Po przeczytaniu tematu widze, ze borykamy sie z tymi samymi problemami - 666MHz / nie wstawanie softu/radia po flashu itp.

ten problem występuje u Ciebie jedynie po Turbo mode ? 

Share this post


Link to post
Share on other sites
jacekb1

Nie, turbo mode odkrylem w pierwszym tescie ze ubija mi soft, po konsultacjach z @shibby ze moze (i jest) to spowodowane taktowaniem pamieci na 666MHz turbo nie wlaczalem w nastepnych testach, potem wrocilem do OFW (bo musialem) i wieczorkiem znowu flash'nolem tomato a tu zonk, albo soft sie nie podnosil albo radio i tak w kolko, walczylem dobre 40min zanim wstalo prawidlowo.

Jesli bedzie taka potrzeba moge rozebrac ACeka i podlaczyc jakiegos jtaga o ile bede wiedzial gdzie i jesli ma on jakies zlacze debug.

  • Like it 1

Share this post


Link to post
Share on other sites
house
a tu zonk, albo soft sie nie podnosil albo radio i tak w kolko, walczylem dobre 40min zanim wstalo prawidlowo.

czyli dokładnie to samo co u mnie :) mniej więcej tyle samo czasu poświęciłem na podniesienie do normalnego stanu (czyszczenie nvram z konsoli, WPS, włączanie radia guzikiem)

Share this post


Link to post
Share on other sites
shibby

no to rozebranie go jest niezbędne w takim razie. Musimy namierzyć co go boli.

 

W środku jest złącze serialowe z pinami (pasuje kabelek CA-42). Drobna uwaga: podłącz rx i tx ale nie podłączaj GND. Włącz router i odczekaj jakies 5sek (aż tylnia dioda zapali się i zgaśnie) i dopiero wtedy podłącz GND. Inaczej nie zobaczysz nic a router ci zwiśnie. Jak już wstanie cały to z konsoli "reboot" i masz całego bootloga.

 

Najlepsze jest to, że 99,99% kernela, libów no i sterowniki wifi są identyczne jak w asusie...

  • Like it 1

Share this post


Link to post
Share on other sites
jacekb1

W środku jest złącze serialowe z pinami (pasuje kabelek CA-42). Drobna uwaga: podłącz rx i tx ale nie podłączaj GND. Włącz router i odczekaj jakies 5sek (aż tylnia dioda zapali się i zgaśnie) i dopiero wtedy podłącz GND. Inaczej nie zobaczysz nic a router ci zwiśnie. Jak już wstanie cały to z konsoli "reboot" i masz całego bootloga.

 

A moze byc cos na PL2303 + Termite, czy polecasz cos innego ?

Powyzsza raczej mi sie sprawdza przy roznych sprzetach.

 

Jaka predkosc portu ?

post-75-0-64659900-1394803671_thumb.jpg

Edited by jacekb1

Share this post


Link to post
Share on other sites
shibby

standardowo 115200 8in1

 

jak ci działał z innymi routerami typu asus. netgear, tplink to z tym też zadziała.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • michalbak
      By michalbak
      Cześć, czy ma ktoś pomysł jak za pomocą routera RT-AC68U zrobić kopię zapasową podłączonego do routera dysku USB do chmury Google Drive?
      W konfiguracji AiCloud 2.0 - AiCloud Sync - widzę tylko Dropbox... Ale może można jakoś ręcznie dodać dysk google?
    • Pakot
      By Pakot
      Czesc,
      informacja dla potomnych. Problem: router w trybie AP wariuje z wifi, zwlaszcza 2,4ghz. Na tyle to upierdliwe, ze dziala jakies 2-3 min. po restarcie, potem calkowicie przestaje, siec pojawia sie i znika co kilka minut, urzadzenia (rozne) nie moga sie polaczyc albo lacza i rozlaczaja. Co ciekawe, po przestawieniu w tryb router wszystko wraca do normy.
      Problem pojawil sie po uaktualnieniu FW do najnowszego 3.0.0.4.382.51610 , ale pozostaje rozniez po cofnieciu do wczesniejszych dostepnych na stronie Asusa: 3.0.0.4.382.51129 oraz 3.0.0.4.382.50624.
      Rozwiazanie:
      zapodac wczesniejszy FW: 3.0.0.4_382_15525, do znaleznienia w sieci.  
    • muzykcb
      By muzykcb
      Cześć.
       
      Koleżanki i Koledzy, co należy zmienić aby połączyć się przez OpenVPN z zasobami sieciowymi.
       
      Windows 10 HOME
      RT-AC68U (najnowsze oprogramowanie ASUSA)+ dysk 4GB
       
      Błędy które OpenVPN wyświetla na czerwono (wersja OpenVPN najnowsza):
       
      WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.
      WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
      There are no TAP-Windows adapters on this system.  You should be able to create a TAP-Windows adapter by going to Start -> All Programs -> TAP-Windows -> Utilities -> Add a new TAP-Windows virtual ethernet adapter.
      Exiting due to fatal error
       
       

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.

Obserwuj nas:

×
×
  • Create New...

Important Information

We use cookies for purposes related to advertising, social media and statistics. By continuing to browse this site, you agree to our use of cookies. All information required in this matter includes: Privacy Policy, Guidelines and Terms of Use.