Jump to content
Sign in to follow this  
muzykcb

RT-AC68U - OpenVPN - konfiguracja

Rate this topic

Recommended Posts

muzykcb

Cześć.

 

Koleżanki i Koledzy, co należy zmienić aby połączyć się przez OpenVPN z zasobami sieciowymi.

 

Windows 10 HOME

RT-AC68U (najnowsze oprogramowanie ASUSA)+ dysk 4GB

 

Błędy które OpenVPN wyświetla na czerwono (wersja OpenVPN najnowsza):

 

WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.

WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

There are no TAP-Windows adapters on this system.  You should be able to create a TAP-Windows adapter by going to Start -> All Programs -> TAP-Windows -> Utilities -> Add a new TAP-Windows virtual ethernet adapter.
Exiting due to fatal error

 

 

1.JPG

Edited by muzykcb

Share this post


Link to post
Share on other sites
house
22 godziny temu, muzykcb napisał:

co należy zmienić aby połączyć się przez OpenVPN z zasobami sieciowymi.

np https://www.asus.com/pl/support/FAQ/1008713/

Share this post


Link to post
Share on other sites
muzykcb
59 minut temu, house napisał:

 

Tak widziałem to na stronie ASUS ale niestety problem jest gdzieś indziej nie wspomnę o oprogramowaniu które ma częściowo inne opcje.

Share this post


Link to post
Share on other sites
house
W dniu 28.04.2019 o 00:45, muzykcb napisał:

There are no TAP-Windows adapters on this system

oznacza, że nie zainstalował się poprawnie klient opnvpn (a tak naprawdę to wirtualna karta sieciowa używana do zestawiania połączenia). Uruchom instalator jako administrator.

Share this post


Link to post
Share on other sites
muzykcb
4 godziny temu, house napisał:

oznacza, że nie zainstalował się poprawnie klient opnvpn (a tak naprawdę to wirtualna karta sieciowa używana do zestawiania połączenia). Uruchom instalator jako administrator.

Miałeś racje, po ponownej instalacji OpenVpn wszystko ruszyło.

  • Like it 1

Share this post


Link to post
Share on other sites
house
Temat został zamknięty jako rozwiązany.

W przypadku jakichkolwiek pytań lub wątpliwości proszę użyć funkcji "Zgłoś odpowiedź". 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • gulashos
      By gulashos
      Cześć może ktoś z Was poda mi pomocną dłoń  zacznę, że korzystam z poradnika: https://openlinksys.info/forum/viewthread.php?thread_id=16352 (niestety tamto forum padło nie można założyć konta). 
      Chce skonfigurować OpenVPNa z interfejsem TAP między Asus RT-AC68U (server na OFW) z adresacją 192.168.1.x a Asus RT-N66U (client na Tomato) z adresacją 10.1.1.x.  Napotkałem kilka na kilka problemów.
       
      Docelowo chce aby 1-2 portów na RT-N66U działały w adresacji 192.168.1.x i stanowiły część sieci gdzie znajduje się RT-AC68U a pozostałe 2 w 10.1.1.x
       
      Startuje server na RT-AC68U wg poniższej konfiguracji:
      http://prntscr.com/puxjgo
       
      na RT-N66U stawiam clienta:
      http://prntscr.com/puxkc7
       
      na RT-AC68U logi wskazują, że połączenie zostało nawiązane:
       
      Nov 10 12:24:54 vpnserver1[7762]: TCP connection established with [AF_INET]91.___.___.___:15132 Nov 10 12:24:54 vpnserver1[7762]: TCPv4_SERVER link local (bound): [undef] Nov 10 12:24:54 vpnserver1[7762]: TCPv4_SERVER link remote: [AF_INET]91.___.___.___:15132 Nov 10 12:24:54 vpnserver1[7762]: write TCPv4_SERVER: Connection reset by peer (code=104) Nov 10 12:24:54 vpnserver1[7762]: Connection reset, restarting [0] Nov 10 12:24:54 vpnserver1[7762]: Closing TUN/TAP interface Nov 10 12:24:54 vpnserver1[7762]: SIGUSR1[soft,connection-reset] received, process restarting Nov 10 12:24:54 vpnserver1[7762]: Restart pause, 1 second(s) Nov 10 12:24:55 vpnserver1[7762]: Static Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Nov 10 12:24:55 vpnserver1[7762]: Static Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Nov 10 12:24:55 vpnserver1[7762]: Static Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Nov 10 12:24:55 vpnserver1[7762]: Static Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Nov 10 12:24:55 vpnserver1[7762]: Socket Buffers: R=[87380->87380] S=[16384->16384] Nov 10 12:24:55 vpnserver1[7762]: TUN/TAP device tap21 opened Nov 10 12:24:55 vpnserver1[7762]: TUN/TAP TX queue length set to 100 Nov 10 12:24:55 vpnserver1[7762]: Listening for incoming TCP connection on [undef] Nov 10 12:25:35 vpnserver1[7762]: TCP connection established with [AF_INET]91.___.___.___:15133 Nov 10 12:25:35 vpnserver1[7762]: TCPv4_SERVER link local (bound): [undef] Nov 10 12:25:35 vpnserver1[7762]: TCPv4_SERVER link remote: [AF_INET]91.___.___.___:15133 Nov 10 12:25:35 vpnserver1[7762]: write TCPv4_SERVER: Connection reset by peer (code=104) Nov 10 12:25:35 vpnserver1[7762]: Connection reset, restarting [0] Nov 10 12:25:35 vpnserver1[7762]: Closing TUN/TAP interface Nov 10 12:25:35 vpnserver1[7762]: SIGUSR1[soft,connection-reset] received, process restarting Nov 10 12:25:35 vpnserver1[7762]: Restart pause, 1 second(s) Nov 10 12:25:36 vpnserver1[7762]: Static Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Nov 10 12:25:36 vpnserver1[7762]: Static Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Nov 10 12:25:36 vpnserver1[7762]: Static Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Nov 10 12:25:36 vpnserver1[7762]: Static Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Nov 10 12:25:36 vpnserver1[7762]: Socket Buffers: R=[87380->87380] S=[16384->16384] Nov 10 12:25:36 vpnserver1[7762]: TUN/TAP device tap21 opened Nov 10 12:25:36 vpnserver1[7762]: TUN/TAP TX queue length set to 100 Nov 10 12:25:36 vpnserver1[7762]: Listening for incoming TCP connection on [undef] ale gdy próbuje sprawdzić czy tunel się zestawił na RT-N66U pingując bramę 192.168.1.1 to nie widzę aby tunel się postawił. 
      Gdy sprawdzam komendą ifconfig:
       
      tap11 Link encap:Ethernet HWaddr ____________________ inet addr:192.168.1.201 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) to widzę, że interfejs TAP11 się postawił i przydzieliło mu adres w teorii z sieci RT-AC68U 192.168.1.x . Coś pominąłem? Na tą chwilę zależy mi aby mieć pewność, że tunel ruszył kwestia portów to temat na później. Nie wiem czy nie muszę przypadkiem czegoś odblokować na routerze na którym stoi Server OpenVPN. Próbowałem generować klucz static zarówno na routerze serverze jak na cliencie (z racji, iż AC68U ma OFW i nie ma "konsoli" generowałem z tamtąd - nie wiem czy to ma znaczenie). 
       
  • Recently Browsing   0 members

    No registered users viewing this page.

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×
×
  • Create New...

Important Information

We use cookies for purposes related to advertising, social media and statistics. By continuing to browse this site, you agree to our use of cookies. All information required in this matter includes: Privacy Policy, Guidelines and Terms of Use.