Jump to content
NivezNo1

Netgear Nighthawk r7000 - Jaki alternatywny firmware wybrać?

Rate this topic

Recommended Posts

sondal

Ja cały czas pracuje na wersji Xwrt-vortex a dokładnie 384.4_2, dodatkowo wgrałem modyfikowane CFE z racji tego iż na razie nie chcę przechodzić na inny firmware.

Share this post


Link to post
Share on other sites
neon
Godzinę temu, sondal napisał:

Ja cały czas pracuje na wersji Xwrt-vortex a dokładnie 384.4_2, dodatkowo wgrałem modyfikowane CFE z racji tego iż na razie nie chcę przechodzić na inny firmware.

ja też jestem na 384.4_2. Modifikowane CFE tzn ? 

Share this post


Link to post
Share on other sites
emer

pisane było wyżej ....

Albo pomyłkowo, albo musiał XVortex zmodyfikować CFE dla wersji FW "NG" (new generation). W kazdym bądź razie jest usunięty (lub zmieniony na Asusa) board id netgerowski i dlatego nawet pliki *.chk nie są identyfikowane jako dla netgeara i dlatego aktualizacja jest odrzucana. Oczywiście nie przyjmuje już *.trx Oprócz tego z CFE wycięto prawidłowy Mac adress routera i "usztywniono" na tylko "US" region dla WiFi (nie wspomnę ze jest tylko automat dla kanałów dla 5GHz).

XVotex chyba nie był świadomy że powrót poprzez to "back to stock" które było na stronie wersja 1.3 cośtam "usztywni" router w tym OFW. Poootem dopiero , jak zobaczył na forum co się dzieje (m.inn ja pisałem), dodał ten spreparowany "back to stock" wersji najnowszej, z której to dość łatwo można "naprawić" router do aktualizacji do wszystkiego co chce się.

IMO nieładnie jednak że XVortex teraz nie przyłoży się bardziej do pomocy userom, którzy wpadli w "back to stock", a tutki wychodzenia z tego impasu userzy sami szukają ..

Edited by emer
  • Like it 2

Share this post


Link to post
Share on other sites
sondal

CFE jest jak bios w PC. Nauczony "gorzkim" doświadczeniem z FW "NG" jak pisał kolega EMER zrobiłem kopię CFE orginalny jak i mod na ASUSA. Ponizej procedura jak zrobic kopie.

1. Odpalamy na ruterze SSH lub telnet administracja-->system--> enable SSH (ja robiłem SSH - Firmware 384.4_2)

2. Odpalamy PUTYY  (Pole: Host Name lub adres IP wpisujemy 192.168.1.1, port zostawiamy 22 --> connection type SSH ---> klikamy OPEN --> pojawia sie terminal gdzie wpisujemy login i hasło do rutera.

3. Wpisujemy następującą komende:  cat /dev/mtd0 > /tmp/home/root/kopia_cfe.bin gdzie zamiast /home/root może być np: dysk USB /mnt/usb lub dysk sieciowy /mnt/sda5   (można zerknac

You do not have the required permissions to view the link content.

4. Jeżeli jest to pierwsza wersja czyli /tmp/home/root odpalasz WinSCP (jak total commander) przechodzisz do katalogu tmp-->home--> root i przenosisz na dysk lokalny swoja kopię CFE

Koniecznym wydaje sie także zrobienie kopi NVRAM (jeszcze nie testowałem). Co niektórzy piszą iz jest to wymagane.(skrypt z załącznika działa na XVortex lub MERLIN)

Lektura do poczytania(sorki że po angielsku) :14_relaxed:https://www.snbforums.com/threads/faq-nvram-and-factory-default-reset.22822/     lub  https://www.snbforums.com/threads/user-nvram-save-restore-utility-r26-2.19521/

Dodatkowo zamieszczam MOD CFE Xvortex wraz z edytorem. Jeżeli będzie potrzebna pomoc jak wgrac CFE napisze prosty poradnik. 

nvram-save-r26.2.zip

r7000-cfe-XVortex.zip

Edited by sondal
  • Like it 3

Share this post


Link to post
Share on other sites
neon

dzięki 

nie zamierzam co prawda wracać na inny FW niż xwrt-vortex, ale wiadomo zawsze może się przydać :) 

Dodatkowo zacząłem używać całego dobrodziejstwa z amtm i jestem bardzo zaskoczony, że R7000 jeszcze daje radę:) 

Pozdrawiam 

Share this post


Link to post
Share on other sites
emer

Połączyłem się poprzez putty z R7000 za pomocą USB-TTL serial (PL2303HX)
Wszedłem do CFE (ctr-c), zadałem komendy burn* dla naprawienia boardID, SN, MACadress, naprawienia WiFi i za każdym razem mam odpowiedź:

You do not have the required permissions to display the content of the code field.

Tzn po każdej burn* mam odpowiedź że "invalid command"

Co robię źle ... pomóżcie proszę :( 

Share this post


Link to post
Share on other sites
house

@emer próbowałeś tego ? : 

You do not have the required permissions to view the link content.

Share this post


Link to post
Share on other sites
emer

tak - nie zapodam chyba normalnego chk , dopóki nie naprawie CFE i prawidłowej identyfikacji burnboardID netgearowskiego.

Próbowałem, a odpowiedź była:

You do not have the required permissions to display the content of the code field.

i powrócił do cholernego zepsutego OFW :( 

rozumiem to tak, że jak widac wyzej jest aktualnie - "Board ID : ▒", (czyli spierdzielone jakieś "▒" )

a zapodany "Image ID : U12H270T00_NETGEAR"

Więc nie przyjął .... najpierw trzeba naprawić CFE. Ale dlaczego nie przyjmuje komend burnboard* ?!

Share this post


Link to post
Share on other sites
house

w której wersji jest CFE ? podobno Netgear go dość mocno okaleczył... Ciekawi mnie, czy zgrywając CFE ze zwykłej wersji dałoby radę załadować

np tak :

You do not have the required permissions to view the link content.
 lub tak : 
You do not have the required permissions to view the link content.
. @emer a próbowałeś wgrać 
You do not have the required permissions to view the link content.
 ?

Share this post


Link to post
Share on other sites
emer

czyli sugerujesz, że skoro nie da się poprawić istniejącego CFE, do wgrać jakis inny dobry (tzn z innego R7000) ?

Share this post


Link to post
Share on other sites
house

dokładnie, zrobić na OFW dump CFE i załadować go na Twoim.

Share this post


Link to post
Share on other sites
emer

myślisz, że po wprowadzeniu do tftpd  :

You do not have the required permissions to display the content of the code field.

gdzie "1_3 flash1.boot" byłby tym dump CFE z innego R7000 ?

To byłoby z cmd, czy z putty i wejściu w CFE ?

Share this post


Link to post
Share on other sites
house

dokładnie, przez putty 

Share this post


Link to post
Share on other sites
emer
27 minut temu, house napisał:

w której wersji jest CFE ? podobno Netgear go dość mocno okaleczył... Ciekawi mnie, czy zgrywając CFE ze zwykłej wersji dałoby radę załadować

np tak :

You do not have the required permissions to view the link content.
 lub tak : 
You do not have the required permissions to view the link content.
. @emer a próbowałeś wgrać 
You do not have the required permissions to view the link content.
 ?

trx nie przyjmuje, ani chk (bo uszkodzony boardID w CFE)

 

to co mi zapodałeś, to plik CFE z R7000 z narzędziem do edycji takiego dumpa ? Tam można wyedytować swoje SN (zaawansowane, pozycja na dole), no i MAC ? Potem zapisać, i taki "swój" CFE zapodać ?

Edited by emer

Share this post


Link to post
Share on other sites
house

trx podejdzie z vortex'a lub tomato.

47 minut temu, emer napisał:

to co mi zapodałeś, to plik CFE z R7000 z narzędziem do edycji takiego dumpa ? Tam można wyedytować swoje SN (zaawansowane, pozycja na dole), no i MAC ? Potem zapisać, i taki "swój" CFE zapodać ?

Wygląda na to, że tak. tutaj masz jeszcze : 

  • stock dump cfe z OFW
    You do not have the required permissions to view the link content.
  • stock dump nvram : 
    You do not have the required permissions to view the link content.

 

Share this post


Link to post
Share on other sites
sondal

Jeżeli chcesz wgrac CEF  przez putty to uzyj następujacych komend:

You do not have the required permissions to display the content of the code field.

<enter>

You do not have the required permissions to display the content of the code field.

<enter> 

You do not have the required permissions to display the content of the code field.

<enter>

 

  • Like it 1

Share this post


Link to post
Share on other sites
emer

strach sie bać ....

czyli:

- wyedytować cfe.bin (tzn dać mój SN i MAC)

- ttl usb serial - R7000<>usb laptop

- putty/serial

- wejście  ctr-c w CFE

- w/w komendy ("cfe.bin" tzn ścieżka do tego "cfe.bin" ?)

 

??

Edited by emer

Share this post


Link to post
Share on other sites
sondal

lub

tftp -m binary 192.168.1.1 -c put R7000-V1.0.9.26_10.2.31.trx (wersja dla LINUX)

lub

tftp -i 192.168.1.1 put R7000-V1.0.9.26_10.2.31.trx (wersja dla Windows - zobacz ten wątek:

You do not have the required permissions to view the link content.
)

 

Share this post


Link to post
Share on other sites
emer

ale mi nie przyjmuje trx ani chk (no i skąd mam wziąć R7000-V1.0.9.26_10.2.31.trx)

mam wrażenie, ze dopóki nie będę miał CFE naprawionego (lub dumpa z innego z moim SN i MAC), to nie przyjmie zadnego FW

Edited by emer

Share this post


Link to post
Share on other sites
emer

Mam tzw "back to stock" XWRT-Votex V1.0.3.80_1.1.38 - ten stary OFW nie ma zaimplantowanego debug.htm i nie mogę dlatego wykonać komend telnetowych naprawiających zepsuty CFE przez najnowsze XWRT-Vortex. Dlatego że jest uszkodzony CFE, to nie mogę upgrade zrobić OFW.chk  (boardID nie netgearowskie). Nie przyjmuje tez *.trx

Dopóki nie naprawie CFE (SN MAC boardID) nic nie wgram innego. Stoje na tym OFW

Dlatego próbowałem USB-TTL serial i putty na serial - powiedzano mi ze tylko tak naprawie CFE. Okazuje się, ze jednak komendy nie działają ...

Edited by emer

Share this post


Link to post
Share on other sites
sondal

Jeżeli nie poradzisz napisz na PW pomogę bez problemu.

Ja osobiście CFE wgrywałem kilka razy ponieważ przez niedopatrzenie wpisałem inny MAC rutera, zamieniłem cyfrę z litera itp.

 

Share this post


Link to post
Share on other sites
emer

czyli nie "naprawiałeś" CFE, ale wgrywałeś jako całość wcześniej wyedytowany pod siebie ?                   

Share this post


Link to post
Share on other sites
sondal

Zrobiłem tak:

1. Wgrałem firmware XVortex V1.0.3.80_1.1.38  ponieważ aby odblokować "DEBUG"  musi byc STOCK FIRMWARE

2. Uruchomiłem procedurę przywrócenia ustawień do stock OFW (procedura z użyciem funkcji telnet)

3. Zrobiłem backup obecnego CFE (NETGEAR)

4. Edytowałem CFE (edytor XVORTEX - cfe modyfikowane przez XVORTEX)

5. Wgrałem CFE modyfikowane

6. Sprawdziłem jak działa i jak jest wersja

7. Edytowałem oryginalne CFE ustawiając mój MAC (edytor XVORTEX)

8. Wgrałem CFE oryginalne

9. Powróciłem do CFE modyfikowanego gdyż zostaje przy XVortex)

 

 

  • Like it 2

Share this post


Link to post
Share on other sites
house
18 minut temu, sondal napisał:

Zrobiłem tak:

1. Wgrałem firmware XVortex V1.0.3.80_1.1.38  ponieważ aby odblokować "DEBUG"  musi byc STOCK FIRMWARE

2. Uruchomiłem procedurę przywrócenia ustawień do stock OFW (procedura z użyciem funkcji telnet)

3. Zrobiłem backup obecnego CFE (NETGEAR)

4. Edytowałem CFE (edytor XVORTEX - cfe modyfikowane przez XVORTEX)

5. Wgrałem CFE modyfikowane

6. Sprawdziłem jak działa i jak jest wersja

7. Edytowałem oryginalne CFE ustawiając mój MAC (edytor XVORTEX)

8. Wgrałem CFE oryginalne

9. Powróciłem do CFE modyfikowanego gdyż zostaje przy XVortex)

@sondal udostępnij swoją kopię oryginalnego CFE, co prawda załączyłem już wyżej link z forum ddwrt, ale jednak zawsze to pewniej. @emer do dzieła, 3mam kciuki :) 

  • Like it 1

Share this post


Link to post
Share on other sites
emer

powoli poddaje sie ... nawet jak modyfikuje cfe.bin w tym edytorze (na mój MAC i SN), to jak chcę zapisać "save as", to nie daje sie ...

No i "troszkę" nie kumam jak zapodać CFE do routera, tzn gdzie te komendy:

Cytat

 

chmod +x ./mtd-write

<enter>

./mtd-write -i cfe.bin -d boot

<enter> 

nvram erase && reboot

<enter>

 

mam wklepywać ... już sie gubię - czy w okienku putty (serial) i po wejściu do CFE ? Po LAN tez połączyć router<>laptop na stałym IP ? tftpd serwer mam uruchomić ?

Edited by emer

Share this post


Link to post
Share on other sites
sondal

Link do mojego CFE wysyłam na PW. Wyśle także link do mod CFE na którym pracuje.

  • Like it 2

Share this post


Link to post
Share on other sites
NivezNo1

Cześć, gdy zresetuję albo wyłączę i włączę ponownie router NetGear R7000. Nie trzyma on w ogóle ustawień. To znaczy ciągle prosi o wpisanie użytkownika i hasła administratora. Owszem, założyłem temat na Forum DD wrt, ponieważ taki firmware wgrałem po xwrt ale nie wiem czy nie ma faktycznie innej drogi i muszę wgrać cfe bin przez specjalny kabel?

 

Link do mojego tematu:

You do not have the required permissions to view the link content.

 

Dzięki za pomoc w rozjaśnieniu sprawy.

Share this post


Link to post
Share on other sites
house

@NivezNo1 przeniosłem Twój temat i połączyłem z obecnym. Poczytaj tę stronę od początku.

Share this post


Link to post
Share on other sites
NivezNo1

@house Hej dzięki za wyrozumiałość. że nie dostałem od razu ostrzeżenia. :D Bo chyba powinienem. Mogłem od początku zacząć dalej czytać. Czy byłaby możliwość, żebyś usunął trzy ostatnie łącznie z tym posty w temacie? Trochę off top. Dzięki z góry, mam nadzieję, że zrozumiesz.

Edited by NivezNo1
  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • dzudzu9
      By dzudzu9
      Witam wszystkich.
       
      Najpierw trochę o mnie
       
      Łącze: 150/15
      Router: TP-Link Archer C1200
      Urządzenia po kablu:
      - TV
      - amplituner
      - XBOX360
      Urządzenia po wifi:
      - 2 telefony
      - tablet
      - laptop z kartą N6300 (N450 2.4 i 5 GHz) + podpięta karta na USB Netgear A6210 (na tym mi najbardziej zależy)
       
      Odległość laptop - router ~7m, w zasadzie bez większych przeszkód (no chyba że drzwi do pokoju z laptopem są zamknięte  ). Żadne kable nie wchodzą w grę, PLC raczej nie da mi więcej i też wykluczam.
      Na karcie N6300 miałem linka w porywach 240-270, SpeedTest max 130Mb/s (N 5GHz).
      Na Netgear A6210 link raczej nie schodzi poniżej 480-530, momentami pokazuje i max karty czyli 866, SpeedTest osiąga max co daje dostawca (AC 5GHz).
       
      Nowy router właściwie nic mi nie da, nie przesyłam danych pomiędzy urządzeniami / usb / nas.
      Mimo wszystko myślę nad zmianą. To co chciałbym osiągnąć:
      - możliwość osiągania jeszcze wyższych transferów (stały link 866, a po zmianie karty / laptopa jeszcze więcej)
      - dobre transfery po USB (pobieranie / "nas")
      - stabilność (co by ludzie nie mówili o TP-linku, ja nigdy żadnych problemów nie miałem: poprzedniego używałem ~10 lat, obecny od pół roku skonfigurowany i działa)
      - mile widziane rozbudowane opcje konfiguracyjne / download manager (wmawiam sobie, że będę się nimi bawił)
       
      Generalnie co byłoby najlepsze w jak najniższej cenie
      - Netgear R6800 (używany, licytacja, zakładam że nie przekroczy ~240zł)
      - Liknsys EA7500 (nowy, 270zł)
      - Asus RT-AC68U (powystawowy, licytacja, zakładam że stanie na ~300-350zł)
       
      O Netgearze i Asusie co nieco wiem, poczytałem testy, opinie, fora (również te) i wiem że są polecane ze wskazaniem na Asusa. O Linksysie niestety nie za wiele informacji. Nie zamierzam wgrywać alternatywnego oprogramowania.
      Jak one wypadają w bezpośrednim porównaniu? Czy warto dopłacać do jednego względem drugiego?
       
      Z góry dziękuję za opinie.
    • OpenITbot
      By  OpenITbot
      Nighthawk M2 (MR2100) to kolejny bezprzewodowy router od firmy NETGEAR, który pozwala na osiągnięcie niezrównanego poziomu dostępu do mobilnej sieci szerokopasmowej oraz niezwykle szybkich połączeń dla wielu urządzeń.

      Kompaktowa obudowa routera mobilnego Nighthawk M2 kryje w sobie procesor Qualcomm SDX24, działający w paśmie 4G (700/900/1800/2100/2600 MHz) oraz 3G (850/900/1900/2100 MHz). Oprócz tego urządzenie, działające w standardzie Gigabit LTE z modemem LTE Cat. 20, zostało zoptymalizowane pod kątem osiągania prędkości pobierania do 2 Gb/s.
       
      Co ważne, M2 został wyposażony w dotykowy ekran LCD (2,4 cale), dzięki któremu zarządzanie siecią i ustawieniami jest niezwykle proste — można wygodnie monitorować zużycie danych, wyświetlać nazwę i hasło sieci WiFi, siłę sygnału sieci komórkowej oraz zarządzać ustawieniami urządzenia i sieci.
       
      Router umożliwia również odciążenie połączenia LTE do opcjonalnego (publicznego lub prywatnego) punktu dostępu za pośrednictwem sieci WiFi lub Ethernet. Sprawia to, że M2 zapewnia szybką alternatywę dla szerokopasmowego dostępu do Internetu bez utraty prędkości - niezależnie od tego, czy przeglądamy Internet, czy też oglądamy ulubione programy. Warto podkreślić, że MR2100 może dostarczyć sieć WiFi dla 20 urządzeń, wykorzystując w tym celu zarówno pasmo 2.4GHz, jak i 5GHz.
       
      Co ważne, urządzenie pozwala na zarówno przesyłanie strumieniowe multimediów z napędu pamięci USB flash lub zewnętrznego dysku twardego do wszystkich podłączonych urządzeń, jak i szybkie przesyłanie filmów podczas podróży. Nie bez znaczenia jest tu również trwały akumulator (5040mAh), zapewniający całodzienną pracę. Z kolei dzięki usprawnionej funkcji Jump Boost można ładować inne urządzenia, gdy poziom naładowania ich akumulatorów jest niski.
       
      Na koniec warto dodać, że M2 nie wymaga oprogramowania do instalacji. Można go zatem w prosty sposób skonfigurować w ciągu zaledwie kilku minut.

      Zobacz cały artykuł

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci.
Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×
×
  • Create New...

Important Information

We use cookies for purposes related to advertising, social media and statistics. By continuing to browse this site, you agree to our use of cookies. All information required in this matter includes: Privacy Policy, Guidelines and Terms of Use.