Skocz do zawartości

Rekomendowane odpowiedzi

nicknowy

Witam,

Czy ktoś z Was może naprowadzić mnie co sprawdzić, co wyłączyć, poprawić, aby po jednej dobie od restartu CPU nie był obciążony non stop w 100% ? Objawia się to tym, iż praktycznie nie można korzystać z interfejsu www (bardzo wolno jest ładowany do przeglądarki), dystrybuowanie sieci działa prawidłowo.

Z tego co zauważyłem to dwa procesy wykorzystują CPU w okolicach 15-20% każdy, są to mtdblock6 oraz kwork.

Ja podejrzewam, że za ten stan odpowiada puchnący plik: /tmp/smb.log, gdyż po jego wyzerowaniu poprzez

> smb.log

wykorzystanie procesora wraca do normalności.

Gdy muszę zrobić tą operację plik smb.log zawiera ~4 000 000 wierszy z treścią Operate= 6.

Nowe wiersze o treści Operate= 6 pojawiają się w pliku w liczbie ~163 000 co godzinę w 3 minuty po pełnej godzinie.

Nie wiem tylko co tworzy te nowe wpisy w logu SAMBY, bo ta operacja mocno obciąża proces, który musi obsługiwać dodawanie nowych wierszy do wielkiego plik w systemie plików. I zapewne ta operacja odbywa się na zasadzie:

  • plik jest otwierany
  • wstawiany jest wiersz Opearate= 6
  • plik jest zamykany

i tak w kółko, aż osiągnięte zostanie te ~163 000 wpisów.

Pozdrawiam

Edytowane przez nicknowy

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

FW 3.0.0.4.378.8150 ? smb włączone ze względu na używany dysk/pendrive usb ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
nicknowy

FW dokładnie ten co podałeś (taki był już fabrycznie zainstalowany). dysk/pendrive nie używany.

Szukałem opcji, gdzie można by wyłaczyć smb ale nie widzę. Procesu smbd też nie widzę uruchomionego.

Edytowane przez nicknowy

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house
3 godziny temu, nicknowy napisał:

Szukałem opcji, gdzie można by wyłaczyć smb ale nie widzę

76 strona tutaj : 

    Zaloguj się lub zarejestruj nowe konto, aby wyświetlić ukryty link.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
nicknowy

Tak to jest jak człowiek nie zajrzy do dokumentacji, bo z przyzwyczajenie szuka czegoś takiego jak usługi w formie jawnej a nie zakamuflowanej.

Natomiast wyłączyłem wszystko co według mnie związane jest z usługami udostępniającymi pliki i niestety o 21:02 do pustego pliku zapisało mi się 180904 wierszy o treści Operate= 6.

Po 20 godzinach od ostatniego czyszczenia pliku smb.log rozmiar 92MB i blisko 3,6 mln wierszy o treści Operate= 6, oczywiście CPU 100% zajętości.

Konfiguracja samby jest chyba tu: /sbin/write_smb_conf ale ten plik jest moim zdaniem w postaci binarnej.

Pod jaką nazwą funkcjonuje proces samby w routerach asusa ?

Edytowane przez nicknowy

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house
9 godzin temu, nicknowy napisał:

Konfiguracja samby jest chyba tu: /sbin/write_smb_conf ale ten plik jest moim zdaniem w postaci binarnej.

poza tym squashfs montowany jest w trybie tylko do odczytu... a zmiany w tmp i ramfs istnieją jedynie do restartu routera.

9 godzin temu, nicknowy napisał:

Pod jaką nazwą funkcjonuje proces samby w routerach asusa ?

smbd

9 godzin temu, nicknowy napisał:

niestety o 21:02 do pustego pliku zapisało mi się 180904 wierszy o treści Operate= 6

poszukaj w konfiguracji smb sekcji związanej z logowaniem zdarzeń, utwórz swój konfig z wyłączoną opcją logowania do pliku, dodaj jako własną konfigurację w /jffs i użyj tego pliku dla wbudowanego smb. Więcej info : 

    Zaloguj się lub zarejestruj nowe konto, aby wyświetlić ukryty link.
 oraz 
    Zaloguj się lub zarejestruj nowe konto, aby wyświetlić ukryty link.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
nicknowy

Dostałem z supportu Asusa najnowszą wersję beta 4G-AC55U_9.0.0.4_382_9661-gb9761031825 firmware i jak ręką odjął, ba nawet jakbym większe prędkości osiągał na interfejsie WAN via modem GSM.

Wystawiona jest tu:

    Zaloguj się lub zarejestruj nowe konto, aby wyświetlić ukryty link.

A wątek z zgłoszeniem:

    Zaloguj się lub zarejestruj nowe konto, aby wyświetlić ukryty link.

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house
Temat został zamknięty jako rozwiązany.

W przypadku jakichkolwiek pytań lub wątpliwości proszę użyć funkcji "Zgłoś ten post". 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Maciek90
      Przez Maciek90
      Mam problem z tym routerem a mianowicie z aplikacją download master. Po podpięciu dysku pod usb klikam "zainstaluj" w zakładce aplikacja usb. Wszystko przebiega pomyślnie, aplikacja się instaluje i na końcu wyświetla komunikat "uruchom download master". Po kliknięciu odsyła mnie ponownie do strony logowania, co jak wczytałem w instrukcji jest rzeczą normalną. Niestety tutaj pojawia się problem, ponieważ nie mogę się zalogować bo wyskakuje komunikat o błędnym haśle lub nazwie użytkownika. Dane logowania wpisuję oczywiście dobre, bo powinny być takie same jak do całego panelu routera. Dodam jeszcze, że robiłem reset do fabrycznych i sprawdzałem inne nośniki i sytuacja się powtarza. Ktoś coś na to poradzi?
    • matthies
      Przez matthies
      Hej
      rozważam zakup tego routera bardzo poważnie. Pytanie tylko czy ktoś może potwierdzić jego działanie z modemami USB?
      Mam Huawei E3372s w wersji HiLink.

      Inna sprawa, w podobnej cenie i z podobnymi funkcjami znalazłem też Fritz 4040. Porównywał ktoś może te dwa urządzenia?

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Więcej wyjaśni nasza Polityka prywatności.