Skocz do zawartości
advert

RT-AC1200G+ wydajność serwera VPN

Rekomendowane odpowiedzi

advert

Mam pytanie odnośnie wydajności serwera VPN na tym routerze. Uruchomiłem na oryginalnym ASUS-WRT serwer VPN (PPTP) , router jest wpięty do światełka 350/350Mbps ; po drugiej stronie mam 100/100Mbit. Niestety transfery z NAS-a po połączeniu się ze zdalnej lokalizacji są więcej niż mizerne: max 700/800 KB/s. Pytanie: czy prędkość po VPN jest ograniczana przez możliwości sprzętowe routera czyli: Broadcom BCM47189 900 MHz, RAM 128MB (parametry nie wydają się aż tak tragiczne). Co ciekawe, próbowałem również testów z wyłaczonym szyfrowaniem (tylko autentykacja) i prędkości są bardzo podobne. Rozumiem że to sprzęt SOHO, ale spodziewałem się trochę lepszych efektów.
Testowo uruchomiłem serwer OpenVPN na NAS-ie (QNAP) który stoi za routerem, transfery są troszkę lepsze (ok. 1,2 MB/s) ale nadal niewystarczające z mojego punktu widzenia.
Czy jest opcja że jest to jakaś ułomność WRT Asusa? Niestety narazie alternatywy nie ma, ale widziałem że w niektórych modelach Asus wypuszczał do swojego softu serwer OpenVPN .
Dzięki z góry za jakieś info, może ktoś testował podobne scenariusze (niekoniecznie w tym modelu).

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house
16 godzin temu, advert napisał:

Pytanie: czy prędkość po VPN jest ograniczana przez możliwości sprzętowe routera czyli: Broadcom BCM47189 900 MHz, RAM 128MB (parametry nie wydają się aż tak tragiczne)

TAK, tylko i wyłącznie przez CPU. Parametry nie wyglądają tragicznie ale należy pamiętać, że wszystko co jest związane z ruchem sieciowym + dodatkowo szyfrowanie tunelu liczy ten sam SoC, więc przy jednordzeniowym CPU jest to dla niego wyzwanie. I to dość spore. 

16 godzin temu, advert napisał:

Rozumiem że to sprzęt SOHO, ale spodziewałem się trochę lepszych efektów.

Lepsze efekty na pewno nie w segmencie SOHO. Może +/- kilka Mb/s więcej da Ci mocniejszy CPU ale szybkie tunele zestawiają routery ze sprzętowym wspomaganiem kryptografii. 

16 godzin temu, advert napisał:

Testowo uruchomiłem serwer OpenVPN na NAS-ie (QNAP) który stoi za routerem, transfery są troszkę lepsze (ok. 1,2 MB/s) ale nadal niewystarczające z mojego punktu widzenia

jak wyżej, nie pamiętam aby sprzętowe instrukcje szyfrowania obsługiwały w QNAPie openvpn, zazwyczaj tylko wolumeny.

16 godzin temu, advert napisał:

Czy jest opcja że jest to jakaś ułomność WRT Asusa? Niestety narazie alternatywy nie ma, ale widziałem że w niektórych modelach Asus wypuszczał do swojego softu serwer OpenVPN .

nie, to nie jest ułomność generalnie Asusa. Możesz pokombinować z długością klucza, kompresją połączenia itp.

16 godzin temu, advert napisał:

może ktoś testował podobne scenariusze (niekoniecznie w tym modelu)

Na RT-AC88U openvpn działa mi mniej więcej tak :

vpntune-compressor.png

ale CPU to dwurdzeniowy Broadcom 1,4 GHz. Na RT-AC68U :

 

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
advert

Dzięki za dużo konkretów. Z opcjami szyfrowania próbowałem, niestety nic to nie daje. Nawet wyłączenie szyfrowania niewiele zmienia. A bezpiecznej alternatywy na połączenie host-LAN nie znajduję. No trudno, trzeba będzie zainwestować w coś szybszego. AC88U - raczej nie chcę tyle wydawać na router, ale przynajmniej wiem w jakim kierunku uderzać. A coś możecie polecić nie-soho ze sprzetowym wsparciem szyfrowania? Może Mikrotik, Draytek?

Wysłane z mojego HTC 10 przy użyciu Tapatalka

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Lokalizacje chcesz spiąć site-to-site czy jedynie remote access ?  

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
advert

Remote access - host z biura do QNAPa którego mam w domu

Wysłane z mojego HTC 10 przy użyciu Tapatalka

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • manol68
      Przez manol68
      Witam. W logach systemych mam dwie różne wiadomości:
       
       
      Ten pojawia się głównie przy ściaganiu plików przy wysokich prędkościach. Mam łącze 1Gb/s.
      Łącze jest stabilne, nie rozłącza się. Co ta wiadomość oznacza i jak naprawić ten problem ?
      Drugi sprawa to urządzenie wifi które ciąglę się rozłacza i łączy ponownie:
       
       
      Jest to dekoder satelitarny nc+ (chip: Sagemcom Broadband SAS).
      Urządzenie łączy się zarówno z siecią 2.4 GHZ jak i 5 GHZ, jakość sygnału i zasięg nie jest tutaj problemem.
      Tu są ustawienia mojej sieci wifi:
       

       
      Czy mogę cokolwiek poprawić / zmienić aby naprawić lub zredukować ten problem ?
      Obie wiadomości pojawiają się niezależnie od użytego firmware, obecnie używam AsusWRT / Merlin 384.10_beta1.
      Z góry dziękuję za pomoc w rozwiązaniu problemu !
       
    • Łukasz_B
      Przez Łukasz_B
      Witajcie
      Mam problem z serwerem VPN asusa. Początkowo postawiony VPN działał bardzo ładnie i miło. Niestety od jakiegoś czasu (może po którymś update'ie) z połączenia VPN może korzystać ostatnio dodany użytkownik.
      W przypadku łączenia za pomocą pozostałych kont użytkowników- nie pozwala nawiązać połączenia i wywala w logach takie coś:
       
      Mar 15 09:50:45 pptp[31886]: pppd 2.4.7 started by admin, uid 0
      Mar 15 09:50:45 pptp[31886]: Connect: pptp0 <--> pptp (188.146.28.8)
      Mar 15 09:50:49 pptpd[31885]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
      Mar 15 09:50:49 pptp[31886]: Peer pawel failed CHAP authentication
      Mar 15 09:50:49 pptp[31886]: Connection terminated.
       

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.

Obserwuj nas:

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Używamy plików cookie do celów związanych z reklamami, mediami społecznościowymi i statystykami. Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Wszystkie wymagane w tej kwestii informacje zawierają: Polityka prywatności, Regulamin oraz Warunki użytkowania.