Jump to content
AsusInfo

Asus RT-N66U z Tomato, DD-WRT i Merlin - wydajność

Rate this topic

Recommended Posts

AsusInfo

Witam wszystkich,

Nie dawno zakupiłem router Ausu RT-N66U i od razu zaczęły się problemy z Wifi 5Ghz. Po przełączeniu kanału od 54 w górę sieć pojawiała się po 1-5 minutach, z dolnymi kanałami takiego problemu nie było.  Zrywało połączenie na 1-5 minut zanim znowu się połączyło. Było oryginalne oprogramowanie więc stwierdziłem że jest BUG w oprogramowaniu, dlatego zainstalowałem AsusWRT-Merlin co nic nie zmieniło. Więc stwierdziłem że jest to wina sprzętu, już chciałem reklamować ale znalazłem kilka podobnych opisów na zachodnich forach dotyczące innych modeli Asusa. Myślę sobie może Merlin ma też tego BUGA w końcu to jest zmodyfikowany AsusWRT.

Czytając takie dobre opinie o Tomato i DD-WRT stwierdziłem że trzeba spróbować zainstalować. Pierwszy poszedł na ogień Tomato, dużo bajerów. No i Eureka wifi 5GHZ nie ma już problemów ale, część ustawień po prostu nie działa. Dobra coś za coś, mając łącze 250Mb/s z UPC zacząłem robić testy jak to chodzi. No niestety oprogramowanie mnie mocno rozczarowało pod względem wydajności:

- test połączenia WAN-Lan 110Mb/s 

- test połączenia po wifi 2.4Ghz 40-50Mb/s 

- test połączenia po wifi 5Ghz 60-70Mb/s

Testy wifi 802.11n były robione w odległości 3 metrów od routera, procesor obciążony w 100% w tym momencie ledwo przeładowywało stronę routera.

Na drugi ogień poszedł DD-WRT, łatwo było przejść z Tomato na niego. Tutaj porażka się okazał jeszcze większa:

- test połączenia WAN-Lan 90Mb/s

- test połączenia po wifi 2.4Ghz 30-40Mb/s

- test połączenia po wifi 5Ghz 50-60Mb/s

Tutaj jeszcze dodatkowo więcej ustawień nie działało poprawnie, ma masę dodatkowych funkcji które też mogą nie działać dobrze. Strona routera przy tych transferach zupełnie nie odpowiadała. Problem z wifi 5Ghz był taki sam jak na oryginalnym oprogramowaniu.

Oprogramowanie alternatywne do tego routera się okazało totalną porażką. Taki firmware jest może i dobry ale dla tanich routerów lub starszej daty, na pewno nie nadaje się do tego modelu. Z tego powodu wróciłem do Merlina na którym są takie prędkości:

- test połączenia WAN-Lan 240Mb/s

- test połączenia po wifi 2.4Ghz 90Mb/s

- test połączenia po wifi 5Ghz 120Mb/s

Włączony Fast-NAT, procesor obciążony maks 30-40%, strona routera bardzo szybko odpowiada. Niestety się znowu pojawił problem z wifi 5Ghz. Nie chciało mi się wierzyć że to wina sprzętu, jak znalazłem podobne pytania ludzi o pomoc na różnych forach z różnego okresu czas (różnych modeli). Zabrałem się dokładnie za analizę co się dzieje z wifi 5Ghz że tak robi. Po kilku dniach prób i błędów stwierdzam że jest to wina naszego "prawa" które nakazuje (gdzieś czytałem) producentom routerów z 5Ghz automatyczne przełączanie pasma DFS, pomimo ręcznego ustawienia przez użytkownika. Jeżeli ustawie kanał od 54 w górę, to i tak sam router szuka najlepszego kanału i to trwa nie raz kilka minut. Zrywanie z kolej wynika z tego ze jest np. na kanale 60 i coś mu się zaczyna mu "nie podobać" (meteo, radary) i zaczyna szukać innego najlepszego, nie raz i kilka minut. Może jak bym zmienił kraj to by sam sprzęt tego nie robił, tego nie wiem. Tutaj nie zależnie czy się ustawi ręcznie czy automat i tak będzie przełączał. Teraz mam ustawione 36/40 i jak na razie od dwóch tygodni nie przełączył.

W oprogramowaniu Tomato jedynie co mi się spodobało to serwer NGINX i SQL, ale się okazało że na Merlina też można postawić serwer WEB z całą resztą. Tak mi się to spodobało że postanowiłem już na Merlinie uruchomić ownClouda. Uruchomiłem ale wydajność okazała się tragiczna takiego rozwiązania, transfery rzędu 100-500Kb/s i procesor obciążony w 100%. Ten sprzęt jest dedykowany do zarządzania ruchem połączeniami a nie pod serwer WEB czy SQL.

Ten cały tekst jest informacją i przestrogą dla wszystkich osób które coś tam chcą modyfikować, zmieniać czy uruchamiać usługi na swoich routerach. niestety takich konkretnych informacji nigdzie nie znalazłem w sieci i przez to straciłem ponad dwa tygodnie na "zabawy" ze sprzętem. Gdybym wiedział to co teraz wiem nie zawracałbym sobie tymi programami głowy, a tym bardziej serwerem WEB. 

Edited by AsusInfo
  • Like it 1

Share this post


Link to post
Share on other sites
house

Podsumowując Twoją wypowiedź warto zaznaczyć, że próbowałeś wykorzystać funkcje webserwera, które trafiły do tomato 2 lata temu na sprzęcie sprzed 4 lat :) To ważne, gdyż  Broadcom BCM4706 to jednordzeniowy SoC taktowany 600 MHz z rodziny MIPS 74K. Dość leciwa konstrukcja, która czasy świetności ma już dawno za sobą, zastąpiona przez wydajniejsze układy ARM. Obecnie stosowane dwurdzeniowe i wyżej taktowane CPU całkiem sprawnie radzą sobie z nginx. Nie jest to co prawda jakieś bardzo wydajne rozwiązanie, ale są tacy, którzy używają i chwalą. Nie wiem dlaczego ten router nadal jest na rynku, i to w nieadekwatnej do możliwości cenie - są szybsze i tańsze rozwiązania - nawet w portfolio samego Asusa - chociażby n18u (brak 5GHz) lub ac1200g+ (single-core cpu, jedynie 128mb ram).

1 godzinę temu, AsusInfo napisał:

Włączony Fast-NAT, procesor obciążony maks 30-40%

tu właśnie leży najważniejszy punkt programu - obsługa fastnat - tomato posiada jego obsługę : 

Wydajność tomato sprawdziłeś z aktywnym modułem ? 

1 godzinę temu, AsusInfo napisał:

Ten sprzęt jest dedykowany do zarządzania ruchem połączeniami a nie pod serwer WEB czy SQL.

Z tym się zgodzę :) 

1 godzinę temu, AsusInfo napisał:

Oprogramowanie alternatywne do tego routera się okazało totalną porażką

Nie stawiałbym tego tak definitywnie, sprawdź wydajność z włączonym CTF, radiem ustawionym na Singapur i transmit power na 0 (ustawienie kontrolowane przez sterownik). Może uda się wykrzesać coś więcej. 

1 godzinę temu, AsusInfo napisał:

dlatego zainstalowałem AsusWRT-Merlin co nic nie zmieniło. (...) Myślę sobie może Merlin ma też tego BUGA w końcu to jest zmodyfikowany AsusWRT

tak to modyfikacja OFW, ale dla tego routera już nie aktualizowana. 

Share this post


Link to post
Share on other sites
AsusInfo

Zainstalowałem najnowszego Tomato i takiej funkcji nie było :))
Instalowanie oprogramowania alternatywnego na tym sprzęcie to tak jakby "wykastrować" sobie sprzęt z wydajności. Na Merlinie mam z wyłączonym Fast-NAT 240Mb/s obciążenie procesora 60-70%

Merlin dalej wspiera RT-N66U, chodzi pewnie o RT-N16U

Edited by AsusInfo
  • Like it 2

Share this post


Link to post
Share on other sites
house
2 godziny temu, AsusInfo napisał:

Zainstalowałem najnowszego Tomato i takiej funkcji nie było

była :) nie mam tomato by shibby pod ręką ale w advancedtomato jest tutaj :

2016-06-09_215548.png

You do not have the required permissions to view the link content.

2 godziny temu, AsusInfo napisał:

Merlin dalej wspiera RT-N66U, chodzi pewnie o RT-N16U

rzeczywiście, masz rację. pomyliłem modele :) 

2 godziny temu, AsusInfo napisał:

Instalowanie oprogramowania alternatywnego na tym sprzęcie to tak jakby "wykastrować" sobie sprzęt z wydajności.

na n66u ? na routerach z AC tak, ale na tym modelu działa w porządku. Miałem ten model dość długo i używałem na nim tomato. 

Share this post


Link to post
Share on other sites
AsusInfo

Te Tomato:

You do not have the required permissions to view the link content.

Tej funkcji Fast-Nat nie ma;)

Apropo wydajności sam się przekonałem na własnej skórze jak to wygląda w rzeczywistości, mając dobre łącze 250Mb/s nie idzie uzyskać nawet połowy pasma.

Edited by AsusInfo
  • Like it 1

Share this post


Link to post
Share on other sites
house
8 godzin temu, AsusInfo napisał:

Te Tomato: (..) Tej funkcji Fast-Nat nie ma

ma jako moduł, tak się go aktywuje :

 

Share this post


Link to post
Share on other sites
AsusInfo

Chyba że tak, ale alpejskie kombinacje :2_grimacing:

Ale i tak jest daleko w tyle z wydajnością, na Merlinie z wyłączonym Fast-Nat daje radę a Tomato nie. Tutaj się potwierdza to co inni podkreślają że największą wadą takiego oprogramowania jest uniwersalność (jest na wszystkie routery). Gdyby były wersje dedykowane to byłby czad pewnie.

Tutaj jeszcze jedną rzecz widzę, że ten test był wykonany na RT-N66U i starą wersją softu. To mam pytanie dlaczego na nowej tak dziadowsko chodzi?? chyba wiem dlaczego. Testy robił z Sambą a nie transferem po HTTP, FTP i etc.

Edited by AsusInfo
  • Like it 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • hjgvcygv
      By hjgvcygv
      Kupiłem ostatnio router Netgear WNR3500L v2 z Advanced Tomato, za główny w tej chwili robi mi D-Link DWR-116(nie ufać marketingowcom, przepłacicie za szmelc 2x). Z internetem łączę się przez modem Huawei E3372 Hilink. Router miał resetowane ustawienia do stanu fabrycznego. Problem polega na tym że po wpięciu do niego modemu i wybraniu go w WAN, router pokazuje że dostęp do sieci ma, jednak ani PC po kablu, ani smartfon po WiFi tego internetu nie widzą.
      W planach mam zrobienie z netgeara głównego routera + NAS(dorzucę hub i dysk 2 TB na USB), a z D-Linka(wgram tomato, jak netgear się okaże stabilny) odbiornika WiFi, by przekazywał dalej sieć po kablu do PC na innym piętrze.
      Będę wdzięczny jak ktoś podrzuci pomysł czemu router nie daje neta dalej...
    • manol68
      By manol68
      Witam. W logach systemych mam dwie różne wiadomości:
       
       
      Ten pojawia się głównie przy ściaganiu plików przy wysokich prędkościach. Mam łącze 1Gb/s.
      Łącze jest stabilne, nie rozłącza się. Co ta wiadomość oznacza i jak naprawić ten problem ?
      Drugi sprawa to urządzenie wifi które ciąglę się rozłacza i łączy ponownie:
       
       
      Jest to dekoder satelitarny nc+ (chip: Sagemcom Broadband SAS).
      Urządzenie łączy się zarówno z siecią 2.4 GHZ jak i 5 GHZ, jakość sygnału i zasięg nie jest tutaj problemem.
      Tu są ustawienia mojej sieci wifi:
       

       
      Czy mogę cokolwiek poprawić / zmienić aby naprawić lub zredukować ten problem ?
      Obie wiadomości pojawiają się niezależnie od użytego firmware, obecnie używam AsusWRT / Merlin 384.10_beta1.
      Z góry dziękuję za pomoc w rozwiązaniu problemu !
       
    • Łukasz_B
      By Łukasz_B
      Witajcie
      Mam problem z serwerem VPN asusa. Początkowo postawiony VPN działał bardzo ładnie i miło. Niestety od jakiegoś czasu (może po którymś update'ie) z połączenia VPN może korzystać ostatnio dodany użytkownik.
      W przypadku łączenia za pomocą pozostałych kont użytkowników- nie pozwala nawiązać połączenia i wywala w logach takie coś:
       
      Mar 15 09:50:45 pptp[31886]: pppd 2.4.7 started by admin, uid 0
      Mar 15 09:50:45 pptp[31886]: Connect: pptp0 <--> pptp (188.146.28.8)
      Mar 15 09:50:49 pptpd[31885]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
      Mar 15 09:50:49 pptp[31886]: Peer pawel failed CHAP authentication
      Mar 15 09:50:49 pptp[31886]: Connection terminated.
       

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.

Obserwuj nas:

×
×
  • Create New...

Important Information

We use cookies for purposes related to advertising, social media and statistics. By continuing to browse this site, you agree to our use of cookies. All information required in this matter includes: Privacy Policy, Guidelines and Terms of Use.