Skocz do zawartości
glorifyday

WAG200G nie przywraca polaczenia po jego utracie...

Oceń temat:

Rekomendowane odpowiedzi

glorifyday

Od jakiegos czasu coraz czesciej moj Linksys WAG200G nie przywraca polaczenia po jego utracie. Swieci sie czerwona dioda statusu ADSL, a w Web UI mozna wyczytac:

DSL Status: Connected
DSL Modulation Mode: ADSL2+
DSL Path Mode: Interleaved
Downstream Rate: 0 kbps
Upstream Rate: 0 kbps
Downstream Margin: 2147483647 db
Upstream Margin: 7 db
Downstream Line Attenuation: 24 db
Upstream Line Attenuation: 5 db
Downstream Transmit Power: 12 db
Upstream Transmit Power: 22 db

Wujek (TFU!) google mowi, ze to 2147483647 db jest wina ISP. WAG200G pokazuje ponoc taka dziwna wartosc, kiedy sygnal na linii jest za slaby.

Jednak mozna sie polaczyc. Pomaga:
- wylaczenie i wlaczenie WAGa,
- (chyba) wypiecie i wpiecie sygnalu ADSL,
- Hard Reboot z Web UI (to nie to samo, co factory reset),
- (edit: nie zawsze) Soft Reboot z Web UI.

Ale nie pomaga:
- disconnect/connect z Web UI.

Generalnie czeka mnie pewnie batalia z dostawca (Orange). ADSL jest dostarczany na linii kiedys nalezacej do TP przez Orange w ramach niesprzedawanej juz przez Orange uslugi Orange Freedom - Internet stacjonarny. Nie wiem, ile to potrwa i jak sie skonczy, ale mysle o opcji B w postaci skryptu wywolujacego w przypadku braku polaczenia na WAGu to samo, co robi Hard Reboot. Sa zasadniczo dwie opcje.

1. Skrypt bedzie sie uruchamial na Synology, Popcornie albo Asusie RT-N16, ktore sa w tej samej podsieci, maja dostep po SSH i mozliwosc instalowania roznego oprogramowania opcjonalnego.

2. Skrypt bedzie wykonywal sam WAG.

Opcja 2 bylaby chyba prostsza do wykonania, ale wymaga zrezygowania z OFW na WAGu. A do tego sie nie kwapie. Obecnie jest tam OFW 1.01.09 i poza zonkiem z polaczeniami dziala bardzo stabilnie. Sygnal WiFi jest stosunkowo mocny, przepustowosc wysyca standard i nie plywa. Szkoda ruszac.

Natomiast jesli nie 2, to skrypt na Synology, Asusie, czy Popcornie musialby niestety symulowac interakcje z Web UI WAGa. Niestety a moze stety, bo to mialoby plusy dodatnie - np. skrypt cyklicznie sprawdzalby komorke Web UI z zewnetrznym IP WAGa. Jakby byla inna niz ostatnio zapamietana, wolalby no noip i zmienial DDNSy, a jakby byla pusta, restartowalby WAGa. I wszystko to w ramach LAN.
Minusy ujemne sa dwa:
- nie wiem, czy sie da,
- nie wiem, jak sie do tego zabrac ;-).

"Nie wiem, czy sie da" z powodu uwierzytelnienia, poniewaz kiedy sprobowalem wejsc na adres
http://user:[email protected]_IP/setup.cgi?next_file=Reboot.htm
to np. mozilla jeszcze raz prosila o potwierdzenie, ze uzytkownik user chce wejsc na strone, a lynx w ogole napisal, ze strona nie zezwala na taka autentykacje i poprosil o dane uzytkownika ponownie.

A "nie wiem, jak sie zabrac", bo nie mam za wielkiego doswiadczenia w interpretowaniu zawartosci stron WWW. Probowalem sie wspomoc Selenium, ale niewiele mi to dalo. Zobaczylem, ze JDownloader ma dla tego rutera jakis skrypt do ponownego laczenia, ale nie wiem, jak taki skrypt przerobic na reboot i jak mozna by go wywolac spoza JDownoadera.

Docenie zatem wszelkie porady od ktorej strony i czym najlepiej problem ugryzc.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

może jakiś stoper prądowy w gniazdku z timerem do power on/off to ogarnie skoro

 

wylaczenie i wlaczenie WAGa,

 

pomaga ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
glorifyday

Tak, pomaga. Zgodnie z tym, co napisalem powyzej.

 

Swoja szosa... czy wiesz cos wiecej o zarzuconym projekcie openwag? Czy moja obawa przed nim jest bezzasadna?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
house

Czy moja obawa przed nim jest bezzasadna?

 

myślę, że tak. widziałem wiele opini pozytywnych - "set and forget" :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
glorifyday

Nie wiesz, ile tam jest oryginalu, a ile rzezby programisty? Czy to jest wynalazek tego typu co Merlin? Bazuje na oryginale i dodaje pare rzeczy?

 

Bo wlasnie aktualny firmware to jest "set and forget" ze stabilnym, zaskakujaco mocnym sygnalem wifi i transferami po wifi wysycajacymi standard. Boje sie ruszac. Ale skrypt rebootujacy latwiej byloby napisac niewatpliwie...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
glorifyday

OK, wspomagajac sie wiresharkiem znalazlem request typu POST, ktory restartuje WAGa. Oto On:

Nie posiadasz wymaganych uprawnień, aby wyświetlać zawartość pola kod.

Zrobilem sobie skrot do takiego URLa  na desktopie - wlacza sie IE, prosi o uzytkownika i haslo do rutera, po czym restartuje ruter.
 

Pozostaje to zapisac jako http request w javie czy jakims innym pythonie (cos konkretnego polecacie do wysylania requestow typu POST w kontekscie uruchamiania tego w skrypcie na ruterze z Tomato?), dodac autentykacje i pewnie oblozyc jakims warunkiem.

 

Ale pierwszy klocek w ukladance mam ;-).

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
glorifyday

Pierwsza, strasznie prosta wersja skryptu juz dziala i zrebootowala wczoraj WAGa.

Uzyte klocki to zamieszczony powyzej URL, curl i grep.

Skrypt dziala na RT-N16 na jffs bez instalacji optware/entware - znalazlem statycznie zbudowana binarke curla i tyle mi do szczescia wystarczylo.

Skrypt w nieskonczonej petli sprawdza "Downstream margin" na WAGu i jak ten jest dziwny, to rebootuje WAGa. Potem zasypia, potem od nowa...

 

Jak bede mial troche wypolerowana wersje, to sie pochwale, moze sie komukolwiek przyda.

 

I tu pytanie do praktykow:

czy sleep w skrypcie jest dozwolone i malo obciaza procesor? Czy sa lepsze metody?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Lukasz1986
      Przez Lukasz1986
      Witam wszystkich na wstępie. 
       
      Posiadam ten router od pół roku i teraz chciałbym się bardziej zagłębić w jego funkcje. Podłączając dysk USB nie mogę przez komputer PC w tej samej sieci kopiować, usuwać ani modyfikować plików na urządzeniu USB. Próbowałem już chyba wszystkiego. Czy instalacja DD-WRT coś zmieni ? Przyznam, że jeśli chodzi o sieci to jestem noga.
       
      Dziękuję za pomoc !
      Łukasz,  
    • pike28
      Przez pike28
      Witajcie . Zakupiłem przełącznik ubiquiti i mam pewien problem z dwoma urządzeniami w sieci .
       
      1. Komputer stacjonarny DELL Optiplex 790 z karta sieciową 1Gb/s . Komputer nawiązuje połączenie ale negocjuje prędkość 10/100 Mbit. Zmiana sterowników nie pomogła kable zarobione poprawnie.
       
      2 PS4. Konsola nawiązuje połączenie z pełnym 1Gb/s ale transfer pobierania plików jest w iście żółwim tempie. Zmiany konfiguracji na konsoli :DNS, MTU nie przynoszą żadnych zmian. Inna konsola PS4 (PRO) również pracuje w sieci i działa poprawnie osiągając maksymalne prędkości pobierania.
       
      Czy w ubiquiti istnieje możliwość sprawdzenia logów dotyczących połączeń i pracy portów ? Nigdzie nie mogę tego znaleźć a dzienniki nic nie pokazują.
       
      Bedę wdzięczny za każdą pomoc.
    • Kojot77
      Przez Kojot77
      Witam wszystkich,
      Posiadam DS216j, 2x WD RED 6 TB, 2 osobne wolumeny, lacze 300/20 Mb/s od Vectry, RT2600ac (zakupiony ostatnio po waszych opiniach ). Komputer po WiFi bez problemu sciaga pliki pelna szerokosia lącza.  Problem polega na tym, ze Transmission nie wykorzystuje lacze na full przy sciaganiu, wysylanie jest ok. Szczytowe osiagi to 120 Mb/s ktore obserwuje na NASie oraz routerze, bo Transmission Remote GUI "dlawi sie" i poki torrent sie nie sciagnie praktycznie nie odpowiada. W trakcie sciagana bez problemu loguje sie z WAN na NAS oraz router. NAS z routerem polaczone gigabitem (nawet wymienilem przewod ostatnio). Jak ogranicze sciaganie w samym transmission do 80-90 Mb/s to RemoteGUI dziala ok. Myslalem ze to moj staruszek Netgear sie nei wyrabial na zakretach, ale niestety na RT2600ac jest to samo. Wiec obstawiam ze to cos z samym transmission jest nie halo tylko nie moge sie dogrzebac co.  Spotkal sie ktos z takim cudem? Jakies podpowiedzi gdzie szukac?
       
      Pozdrawiam

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.

Obserwuj nas:

×

Powiadomienie o plikach cookie

Używamy plików cookie do celów związanych z reklamami, mediami społecznościowymi i statystykami. Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Wszystkie wymagane w tej kwestii informacje zawierają: Polityka prywatności, Regulamin oraz Warunki użytkowania.