Jump to content
Sign in to follow this  
MarekS

Synology DS212j - wolny dostęp do danych, otwarcie folderów.

Rate this topic

Recommended Posts

MarekS

Witam,

od pewnego czasu mam zgłoszenia od użytkowników mojej sieci firmowej pracujących pod windows7, 8, 10 o powolnym otwieraniu się folderów sieciowych. Ja aktualnie pracuję jeszcze kilkanaście osób na Windows xp i nie zauważam takiego objawu ani reakcji (foldery otwierają się powiedzmy normalnie - po kliknięciu w folder 1sec i otwarte). Natomiast na nowszych Windowsach 7, 8 ,10 otwarcie folderu trwa około 5-8 sec. Sprawdzane już było wszystko na różnych komputerach, z antywirusem i bez,  różne foldery, różne uprawnienia. Po otwarciu zasobów i wejściu do folderu praca na plikach (kopiowanie, kasowanie) wygląda normalnie. Serwer podpięty jest to 1Gb switch. Proszę o pomoc bo nie wiem gdzie szukać problemu. Mam również mały serwerek plików ale firmy LENOVO EZ i tam nie ma tego efektu. Czy windows xp czy 7 wejście, otwarcie folderu trwa od 1-2 sec.

 

Pozdrawiam Marek

 

Share this post


Link to post
Share on other sites
house

jak wygląda obciążenie cpu/ram/dysku ? przeglądałeś monitor zasobów ? która wersja DSM ?

Share this post


Link to post
Share on other sites
MarekS

CPU - od 7 do 51%

RAM -od 40 do 55%

DSM 5.2-5644

Dyski wolne w 65 %

Monitor zasobów okrojony do minimum.

Share this post


Link to post
Share on other sites
house

w wierszu poleceń wpisz 

Sorry, only registered users can display code field :(

i sprawdź czy włączona jest funkcja autotuningu 

Sorry, only registered users can display code field :(

wtedy wklep polecenie :

Sorry, only registered users can display code field :(

i sprawdź czy została wyłączona pierwszym poleceniem. Znacząco poprawia to obsługę zapytań dns, przeglądanie otoczenia sieciowego i udostępnionych folderów. Gdybyś zanotował znaczący spadek wydajności w transferach zmień tę opcję na :

Sorry, only registered users can display code field :(

Dodatkowo możesz wyłączyć algorytm RDC co również usprawni połączenia z NAS'em :

Sorry, only registered users can download attachments :(

na koniec :

Sorry, only registered users can display code field :(
5 godzin temu, MarekS napisał:

Ja aktualnie pracuję jeszcze kilkanaście osób na Windows xp i nie zauważam takiego objawu ani reakcji (foldery otwierają się powiedzmy normalnie - po kliknięciu w folder 1sec i otwarte).

Windows XP nie obsługuje tych funkcji więc dlatego nie widzisz tych problemów. Część z nich została wprowadzona dopiero w Windows Vista.

Share this post


Link to post
Share on other sites
SteelRat

Witam serdecznie,

temat może i stary, ale problem mam podobny, występował na DS713+ a teraz na RS815+, foldery udostępnione otwierają się po kilkanaście sekund, zarówno w XP jak i nowszych systemach, zastosowanie podanego rozwiązania nie pomogło niestety wcale.

Ds815+ zaktualizowany do najnowszej wersji.

Na chwilę pomaga "wyczyść pamięć podręczną SMB" w ustawieniach zaawansowanych "usług plików".

Łączenie z zasobami udostępnionymi z serwera 2012R2 nie stwarza problemów, jedynie z Synology (2 lokacje, połączone wydzielonym tunelem - objaw identyczny w obu), inne kwestie związane z siecią nie występują, tylko z tymi nieszczęsnymi folderami udostępnionymi, może się komuś coś podobnego zdarzyło, lub zna rozwiązanie?

 

Przypominam, że u mnie "12-sekundowe otwieranie" występuje niezależnie od systemu operacyjnego.

PS - problem ten występuje tez przy kopiowaniu, tj, gdy zacznę kopiować dane, osiągam maksymalne transfery w sieci, ale próba otwarcia zamapowanego folderu kończy się 12 sekundową "zadyszką" i cały ruch zostaje wstrzymany, bo potem ruszyć na nowo.

Edited by SteelRat
PS

Share this post


Link to post
Share on other sites
house

@SteelRat mam ten sam problem, 40 hostów w sieci, 3x DS1515+, 1x DS1815+ i na tym ostatnim dostęp do serwera trwa około 20 sekund. Nie ma znaczenia wersja systemu operacyjnego - w sieci pracują końcówki praktycznie z każdą wersją od XP, oprócz Windows 8.1. Mam otwarte zgłoszenie w tej sprawie w Synology - dam Ci znać o wynikach. Czasem oprócz czyszczenia pamięci podręcznej SMB pomagało włączenie SMB2 zamiast SMB3 z wyłączonym trybem szyfrowania transferu. 

Share this post


Link to post
Share on other sites
SteelRat

dzięki wielkie za odpowiedź house, niedawno się przesiadałem z 713, tam problem tez w sumie występował.. czasami, użyszkodników jest tam może 20-30, na bieżąco siedzą i klepią różne dokumenty i narzekają ostatnio potężnie. Czyściłem cache SMB - u mnie pomagało na 15 sekund... zdalnie korzystam tęz z XPka w drugiej lokalizacji i na obu testuję, zmieniałem poziom SMB (na 1 nie było żadnej komunikacji, na pozostałych sytuacja taka sama wciąż) stary 713 i drugi RS815+ mam u siebie w głównej lokalizacji, ale 713 dopiero będę od nowa konfigurować, a 815 nie stwarza żadnych problemów - jest w sumie tylko miejscem zrzucania backupów.

Share this post


Link to post
Share on other sites
house

Dam Ci znać @SteelRat jeśli coś wyniknie - uprzedzam, że sprawa ciągnie się dość długo a technicy Synology nie za bardzo wiedzą jak rozwiązać ten problem :/ 

Share this post


Link to post
Share on other sites
SteelRat

Ciekawie...

A u siebie testuję i... 3 podpięte udziały, z tego samego woluminu, 1 otwiera natychmiast, pozostałe dwa z opóźnieniem 12s.

I obojętne, czy po nazwie łączę (musi rozwiązać przez DNS), czy po IP.

Share this post


Link to post
Share on other sites
house

ten problem wydaje się być związany z uwierzytelnieniem użytkownika i sprawdzeniem uprawnień do danego zasobu sieciowego na serwerze. Nie pomaga przełączenie kart sieciowych w LAG, zmiana switch'a, okablowania - problem ewidentnie siedzi gdzieś w DSM. @SteelRat - jakiego systemu plików używasz w DSM ? u mnie problem występował przede wszystkim na EXT4, po konwersji wolumenu do Btrfs problem na razie znikł.

Share this post


Link to post
Share on other sites
SteelRat

@house - Na 713 jest EXT-4, na 815 jest btrfs ;)

A żeby dokonać konwersji na inny, to bym musiał od nowa parę ładnych setek gigabajtów przerzucić i skonfigurować... Obecnie sezon zestawień, sprawozdań, poeksperymentuję na 713 chyba, tylko brak czasu niestety wciąż.

Share this post


Link to post
Share on other sites
SteelRat

@house - zweryfikowałem, naprawiłem, podobno.

 

U mnie problem leżał w podmontowanych folderach prawdopodobnie - używane były do migracji między urządzeniami. Póki co działa podobno ok, poczekam kilka dni.

(czy powinienem dać nowy post, czy wyedytować poprzedni, sprzed kilku dni?)

Share this post


Link to post
Share on other sites
house
3 minuty temu, SteelRat napisał:

U mnie problem leżał w podmontowanych folderach prawdopodobnie - używane były do migracji między urządzeniami. Póki co działa podobno ok, poczekam kilka dni.

nie wiem czy to ma związek, nie używałem montowania folderów a problem występował.

4 minuty temu, SteelRat napisał:

(czy powinienem dać nowy post, czy wyedytować poprzedni, sprzed kilku dni?)

obojętnie... edycja i tak jest możliwa tylko do 6 dni :) 

Share this post


Link to post
Share on other sites
SteelRat

A webowo przez "file station" się łącząc problem masz? Bo u mnie był też, tylko, co dziwne, wcześniej go nie zauważyłem.

System plików, jak pisałem już, na "wadliwej" maszynie to btfrs, ale na 713 też narzekali, może kwestia wydajności? Ok. 40 podpiętych osób. A i sieć "połatana" z gigabitu i setek, switchy spiętych na trasie też, teraz dopiero zmiany struktury będą wdrażane, bo nowa struktura wreszcie jest, więc się "rozdzielające" switche powycina.

Share this post


Link to post
Share on other sites
house
3 godziny temu, SteelRat napisał:

A webowo przez "file station" się łącząc problem masz? 

nie, tylko i wyłącznie poprzez smb. 

3 godziny temu, SteelRat napisał:

System plików, jak pisałem już, na "wadliwej" maszynie to btfrs, ale na 713 też narzekali, może kwestia wydajności? Ok. 40 podpiętych osób. A i sieć "połatana" z gigabitu i setek, switchy spiętych na trasie też, teraz dopiero zmiany struktury będą wdrażane, bo nowa struktura wreszcie jest, więc się "rozdzielające" switche powycina.

u mnie wszystko na gigabicie - switche cisco, zyxel i netgear - wykluczyłem problem w tym miejscu przepinając NAS'y pomiędzy nimi, likwidując i tworząc bond LAG - niestety problem występował. Zrobiłem jednej nocy synchronizację udziałów sieciowych na nową maszynę, zmieniłem nazwę fqdn, poprawiłem uprawnienia dla kont z AD i problem ominąłem a starą maszynę zostawiłem w stanie niezmienionym do zgłoszenia w supporcie Synology.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • OpenITbot
      By  OpenITbot
      Firma Synology wprowadziła dziś na rynek serwer RackStation RS820+/RS820RP+, 4-kieszeniowy serwer NAS do montażu stelażowego w obudowie 1U, zaprojektowany z myślą o wysokiej wydajności transmisji danych i skalowalności pamięci masowej na potrzeby średnich biur.

      Kluczowe funkcje serwera RS820+/RS820RP+:
      4-rdzeniowy procesor 2,1 GHz z obsługą interfejsem AES-NI 2 GB pamięci DDR4 z możliwością rozszerzenia do 18 GB Możliwość skalowania do 8 napędów przy użyciu jednostki Synology Expansion Unit RX418 Jedno gniazdo PCIe 3.0 na opcjonalną dodatkową kartę sieciową 10GbE lub kartę M2D18 M.2 SSD Zaawansowany system plików Btrfs oferujący 65 000 migawek dla całego systemu i 1 024 migawki na folder współdzielony Funkcja Synology High Availability (SHA) umożliwiająca nieprzerwane działanie i płynne przechodzenie między serwerami w klastrach Obsługa przez system Synology DiskStation Manager  
      Serwer RS820+/RS820RP+ pracuje pod kontrolą DiskStation Manager, zaawansowanego i intuicyjnego systemu operacyjnego dla urządzeń Synology NAS oraz zapewnia różne aplikacje zwiększające produktywność. Firma Synology otrzymała wiele przychylnych opinii mediów, trafiając na szczyty rankingów serwerów NAS do średnich obszarów roboczych w ankiecie dotyczącej rozwiązań pamięciowych TechTarget oraz zdobywając nagrodę czytelników PCMag przez dziewięć lat z rzędu.
       
      Dowiedz się więcej:
      Szczegóły dotyczące modelu RS820+/ RS820RP+
      https://www.synology.com/pl-pl/products/RS820+
      Szczegóły dotyczące modelu RS820+/ RS820RP+
      https://www.synology.com/pl-pl/products/RS820+#specs
      Szczegóły dotyczące rozszerzonej gwarancji EW202
      https://www.synology.com/pl-pl/products/Extended_Warranty

      Zobacz cały artykuł
    • OpenITbot
      By  OpenITbot
      Firma Synology wprowadziła dziś na rynek serwer RackStation RS820+/RS820RP+, 4-kieszeniowy serwer NAS do montażu stelażowego w obudowie 1U, zaprojektowany z myślą o wysokiej wydajności transmisji danych i skalowalności pamięci masowej na potrzeby średnich biur.

      Sorry, only registered users can download attachments :( Kluczowe funkcje serwera RS820+/RS820RP+:
      4-rdzeniowy procesor 2,1 GHz z obsługą interfejsem AES-NI 2 GB pamięci DDR4 z możliwością rozszerzenia do 18 GB Możliwość skalowania do 8 napędów przy użyciu jednostki Synology Expansion Unit RX418 Jedno gniazdo PCIe 3.0 na opcjonalną dodatkową kartę sieciową 10GbE lub kartę M2D18 M.2 SSD Zaawansowany system plików Btrfs oferujący 65 000 migawek dla całego systemu i 1 024 migawki na folder współdzielony Funkcja Synology High Availability (SHA) umożliwiająca nieprzerwane działanie i płynne przechodzenie między serwerami w klastrach Obsługa przez system Synology DiskStation Manager  
      Serwer RS820+/RS820RP+ pracuje pod kontrolą DiskStation Manager, zaawansowanego i intuicyjnego systemu operacyjnego dla urządzeń Synology NAS oraz zapewnia różne aplikacje zwiększające produktywność. Firma Synology otrzymała wiele przychylnych opinii mediów, trafiając na szczyty rankingów serwerów NAS do średnich obszarów roboczych w ankiecie dotyczącej rozwiązań pamięciowych TechTarget oraz zdobywając nagrodę czytelników PCMag przez dziewięć lat z rzędu.
       
      Dowiedz się więcej:
      Szczegóły dotyczące modelu RS820+/ RS820RP+

      Sorry, only registered users can display links :( Szczegóły dotyczące modelu RS820+/ RS820RP+

      Sorry, only registered users can display links :( Szczegóły dotyczące rozszerzonej gwarancji EW202

      Sorry, only registered users can display links :(
    • neon
      By neon
      Dziś dodałem do Ac2600ac Mesha i ustawiłem wszystko na auto. niestety często Mesh informuje o: "Synology mesh niestabilne połączenie z punktami wifi." Co można zmienić w ustawieniach, żeby poprawić na lepsze połączenie z punktami wifi? Próbowałem co nieco zmieniać, ale jest tak samo. Może macie jakieś sprawdzone ustawienia ? 
       
      Pozdrawiam
       

openitforum.pl

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci.
Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×
×
  • Create New...

Important Information

We use cookies for purposes related to advertising, social media and statistics. By continuing to browse this site, you agree to our use of cookies. All information required in this matter includes: Privacy Policy, Guidelines and Terms of Use.