Skocz do zawartości
no4fly1

Asuswrt-Merlin nie działa FTP

Rekomendowane odpowiedzi

no4fly1    8
no4fly1

Witam

po zmianie firmowego oprogramowania na Merlina nie działa mi FTP.

W czym może być problem?

Podpięty pod USB dysk jest widoczny w sieci lokalnej, ale nie ma do niego dostępu z sieci zewnętrznej.

Przed zmianą firmware wszystko działało.

Wszystkie ustawienia mam bez zmian.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house

po zmianie firmowego oprogramowania na Merlina nie działa mi FTP. W czym może być problem?

przekierowanie portu ? sprawdzasz łącząc się ze swojego LAN'u poprzez publiczny adres, czy z zupełnie innej sieci ?

FTP jest włączone? dysk USB widać w lan po smb czy właśnie ftp ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

dziękuję za wyodrębnienie wątku oraz za odpowiedź

 

Przekierowanie nic nie daje zresztą na OFW działało przekierowanie automatycznie.

Włączone Aidisk.

DDNS zarejestrowane i nie pokazuje błędu.

 

Przy takich ustawieniach i z tym samym dyskiem działało na RT-N66U oraz po zmianie na RT-AC68U (na OFW)

a po wgraniu Merlina przestało.

 

Sprawdzam poprzez publiczny adres (przez sieć komórkową tak dotychczas działało)

W lokalnej sieci dysk widać zarówno po smb jaki ftp.

Edytowane przez no4fly1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house

używasz host.asuscomm.com ? pokaż jakiś kawałek logu z routera i klienta ftp, problem może dotyczyć listowania katalogów lub trybu passive. rzeczywiście router sam dodaje reguły nat do usług ftp, spróbowałbym przekierować jakiś inny port np 8080 do 21 z ip routera i sprawdził. za mało danych, poza tym, że nie działa.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house

z którego wynika tylko tyle, że serwer działa a nie odpowiada na WAN. Przekieruj ręcznie port 8080 do 21 i sprawdź.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

niestety ustawienie przekierowania nic nie dało

 

 


natomiast przy takim ustawieniu klient ftp daje z sieci zewnętrznej komunikat że nie można znaleźć serwera,

a łącząc się po sieci wewnętrznej - wywołaniu host.asuscomm.com łączy się, no ale nie o to przecież chodzi. 

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

Edytowane przez no4fly1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house

a powrót do OFW przy takich samych ustawieniach coś poprawia ? zainstaluj FileZilla server, wystaw na WAN i spróbuj się połączyć. Reset ustawień i ustawienie od nowa wykonałbym jako ostateczność.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

po przywróceniu OFW

 

ftp działa,

 

nie widać katalogów, bo Merlin pozmieniał nazwy, ale to pewnie kwestia ponownego uruchomienia AidDisk,

ale na dysk można się dostać.

 

 

edit 1:

katalogi już się same pojawiły

 

na OFW usunąłem przekierowanie 8080 na 21 i ftp dalej działa z sieci zewnętrznej

 

 

edit 2:

po ponownym wgraniu Merlina klient ftp z zewnątrz przestał się łączyć.

żadnych zmian w ustawieniach nie wprowadzałem

 

 

 

Macie może jeszcze jakieś pomysły czy lepiej wrócić do OFW?

Edytowane przez no4fly1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house

zapisz ustawienia do pliku w OFW, wgraj merlina i zresetuj do ustawień fabrycznych. Ustaw od nowa, jak nie pomoże - wgraj OFW i przywróć ustawienia z pliku.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

na wgranym Merlinie, reset do fabrycznych

zmieniłem login i hasło 

uruchomiłem od nowa ddns 

 

nie działa

 

trudno, wracam do OFW

szkoda

 

 

dzięki za dobre chęci i poświęcony czas

Edytowane przez no4fly1
  • Lubię to 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
muzykcb    106
muzykcb

A w ustawieniach:  Udostępnianie FTP włączyłeś:

 

1) Włącz FTP

2) Enable WAN access

 

w OFW nie ma takiej potrzeby merlin wymaga włączenia.

    Dodaj reakcję lub odpowiedz w tym temacie, aby zobaczyć ukrytą zawartość.

 

  • Lubię to 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

 

 

Wszystkie ustawienia mam bez zmian.

 

Na pewno nie włączałem dostępu WAN.

Po powrocie do OFW ftp działa.

 

Dzięki za podpowiedź.

Zobaczymy czy to było to.

 

Przy okazji po co w Merlinie ta opcja wyłączania WAN access?

Jakie są tego plusy i minusy?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
house    1389
house
Przy okazji po co w Merlinie ta opcja wyłączania WAN access? Jakie są tego plusy i minusy?

@muzykcb pyta czy włączyłeś dostęp zewnętrzny, jeśli nie to masz przyczynę. Ja błędnie założyłem, że oczywiście go włączyłeś i dopiero po tym sprawdzasz z WAN'u dostęp :) Plusem jest to, że możesz zdecydować czy serwer ma działać jedynie w sieci lokalnej czy ma być dostępny z zewnątrz. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
no4fly1    8
no4fly1

Potwierdzam - po włączeniu WAN Access dostęp przez ftp z sieci zewnętrznej działa.

Czyli to było to, dzięki muzykcb.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Podobna zawartość

    • Portal
      Przez Portal
      Witam
      Mam wgrany w ac68 najnowszego Merlina (380.68). Czasami co kilka dni, lub nawet kilka razy w ciagi dnia nagle transfer internetu spada. Prze resetuje router i znowu prędkość wraca do normalnej. Łącze mam 300/300 i jak prędkość spada to tak do 150/40 mbit/s. Wiecie co może być ?
      Dodam ze jak instalowałem 380.68 to wszystko ręcznie ustawiłem od nowa, więc nie powinno być pozostałości po starszych wersjach. Zauważyłem również ze jak spada prędkość internetu to w logach routera jeden z laptopów (wifi), mimo ze kilka urządzeń jest podłączonych, cały czas ma wznawiane IP z dhcp
      Aug 27 09:12:23 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:13:55 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:13:55 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:14:00 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:14:00 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:14:06 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:14:06 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:14:10 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:14:10 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:19:03 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:19:03 dnsmasq-dhcp[477]: DHCPACK(br0) Aug 27 09:21:48 dnsmasq-dhcp[477]: DHCPREQUEST(br0) Aug 27 09:21:48 dnsmasq-dhcp[477]: DHCPACK(br0) Dodam również ze nie mam włączonego żadnego QOS-a ani innych bajerów do zarządzania pasmem itp - standardowe ustawienia.
      Dzieje sie to po wifi jak i po LAN.
    • OpenITbot
      Przez OpenITbot


      Zobacz plik ASUS RT-AC68U Firmware
      ASUS RT-AC68U Firmware
      Dodający OpenITbot Dodano 14.02.2014 Kategoria ASUS  
    • Maff
      Przez Maff
      Cześć,
      od jakiegoś czasu mam problem z oprogramowaniem Asuswrt-Merlin, a dokładnie z zainstalowanym klientem Transmission na moim AC87. Otóż jakies 2 miesiące temu (nie pamiętam, która wersja softwaru Merlina) Transmission przestał działać - a dokładnie po parudziesięciu sekundach od rozpoczęcia pobierania pliku wiesza się (tramisnssion przestaje odpowiadać, trzeba go zresetować) - cała reszta (router, internet) działa bez problemu. Dzieje się tak zawsze. Co ciekawe, gdy zainstalowałem oryginalne firmware asusa (najnowszy) problem nie występuje. Jakieś pomysły co to może być?
       

Openitforum

Forum poświęcone przesyłaniu i przechowywaniu danych w małej sieci. Prezentujemy testy urządzeń oraz pomagamy w ich obsłudze i konfiguracji.
×

Powiadomienie o plikach cookie

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies. Więcej informacji zawiera nasza Polityka prywatności